SATA zu SCSI ohne Neuinstallation Server 2012 R2

  • Hallo zusammen

    Ich habe auf meinem Root Server einen Windows Server 2012 R2 installiert. Der einfachheithalber habe ich das Ganze bei der Installation mit einer SATA HDD durchgeführt.

    Nun habe ich aber festgestellt das es bei diesem Server immer wieder mal zu Hängern mit einer Dauer von ca. 45 Sekunden kommt.

    Dies wird durch das Event 129 - Reset to device, \Device\RaidPort0, was issued bestätigt.

    Nun würde ich gerne auf SCSI umstellen. Den Treiber habe ich installiert.

    Wenn ich nach der Umstellung auf SCSI den Server boote kommt es immer zu BlueScreens und einen anschließenden Reboot.

    Gibt es eine Möglichkeit auf SCSI umzustellen ohne das ich das System neu installieren muss?

    Bin für jeden Tipp dankbar.

    Viele Grüße

    Thomas

  • Hi Thomas,


    bei mir hat das genau so (auf einem selbst gehosteten Server) funktioniert.

    Den SCSI treiber aus der Virtio CD installiert, den Gast herunter gefahren, Plattencontroller geändert, den Gast wieder hoch gefahren.


    Wo bei dir der Fehler liegt (oder in unseren Setups der unterschied liegt) kann ich leider nicht sagen.


    Hast du nur einen Reboot gemacht oder die Kiste mal komplett aus gemacht und wieder an gemacht?

  • Hay,


    ich hatte etwas ähnliches bei Windows Server 2008. Ursache war, dass aus irgendeinem Grund SCSI-Devices nicht per plug und play erkannt wurden. Ich habe mir leider die Quelle nicht archiviert, aber mir damals die Arbeitsschritte rauskopiert - vielleicht ists ja dasselbe bei Dir & Windows Server 2012. Da aber regedit im Spiel ist KEINE Garantie :saint:und backup vorher empfiehlt sich sowieso, falls schon produktive Dinge auf dem Server sind...


    Danach wurde der neue Treiber dann in echt gesucht, gefunden und eingebunden.


    CU, Peter

  • Hallo Lukay und CmdrXay

    Vielen Dank für die Tipps und Hinweise. Leider hat nichts geholfen. Ich komme immer wieder in den BlueScreen.

    Somit gebe ich auf. Habe einfach meine vier Server neuinstalliert mit einer SCSI Platte.

    Die Migration der Applikationen und Daten war in dem Falle einfach.

    Einzig mein Server der richtig Arbeit bedeutet bei der Migration habe ich noch nicht angefasst.

    Bei dem habe ich einfach von SATA auf IDE umgestellt. und seitdem kommt es nicht mehr zu den Events und auch nicht mehr zu den Hängern.

    Performance ist in dem Falle nicht so wichtig. Von daher lasse ich es jetzt einfach so.

    Viele Grüße

    Thomas