DNS-Einträge für IPv6

  • Guten Tag,


    ich habe seit ein paar Tagen einen VPS 1000 G7SEa1 12M gemietet.

    Von einem Mitbewerber habe ich eine Domain transferiert, die entsprechende Webseite hoste ich nun auf dem VPS.


    Des Weiteren habe ich per Postfix/Dovecot einen Mail-Server installiert, der soweit auch super funktioniert (Senden über 587, Empfangen über 993 klappt).

    Problematisch ist das Verbinden auf den SMTP-Server mit einer IPv6 Adresse (bspw. über meinen Hybrid-Anschluss Zuhause). Wenn ich es aus dem Mobilnetz (auf meinem Smartphone - mit IPv4) versuche, klappt alles einwandfrei.


    Meine Vermutung war, dass der Server nicht für IPv6 konfiguriert wäre, was auch der Fall war, weshalb ich die Wiki-Anleitung zum Konfigurieren einer IPv6-Adresse benutzt habe.

    Das scheint soweit auch geklappt zu haben, da mir ifconfig die statisch konfigurierte IP-Adresse ausgibt.


    Im SCP habe ich einen rDNS-Eintrag für die o.g. IPv6-Adresse eingetragen (der Hostname ist identisch mit dem rDNS-Eintrag für die IPv4-Adresse), was auch gespeichert wurde.

    Bisher funktioniert der Verbindungsaufbau damit per IPv6 leider nicht.


    Meine nächste Vermutung ist, dass entsprechende DNS-Einstellungen nicht gesetzt sind - bevor ich mich an die Konfiguration wage, wollte ich allerdings lieber etwas Hilfe einholen, da ich mich nicht gerade als "fortgeschrittenen Benutzer" bezeichnen kann. ;)


    Ab hier dann die Frage: Hat jemand spontan eine Idee, was mein Problem lösen könnte?

    Config-Dateien kann ich auch Nachfrage gerne hier posten.


    Vielen Dank im Voraus und ein sonniges Wochenende!

  • Hi,


    vielen Dank für den Hinweis. Die DNS-Einstellungen habe ich nun um folgende AAAA-Einträge erweitert:


    Unbenannt.png

    Ein ping von außerhalb auf die IPv6-Adresse funktioniert, ebenfalls auf die Domain per IPv4.

    Sobald ich es (Windows) mit ping -6 domain.tld probiere, meldet mir die Shell, dass der Hostname nicht aufgelöst werden kann.


    Ich habe es noch vom VPS direkt getestet per ping6 domain.tld - auch hier "unknown host". Dass von extern nicht direkt aufgelöst werden kann, verstehe ich, daher ja auch der Hinweis mit den 48 Stunden. Der VPS benutzt aber die Nameserver von netcup, womit doch eigentlich direkt aufgelöst werden können sollte.


    Da der Server von extern über beide (IPv4/v6) Adressen erreichbar ist, scheinen noch irgendwelche DNS-Einstellungen nicht korrekt zu sein.

    Ist da in meiner Konfiguration direkt irgendetwas ersichtlich?

  • Hay,

    Der VPS benutzt aber die Nameserver von netcup, womit doch eigentlich direkt aufgelöst werden können sollte.

    Neee :) Logisch ja, aber meiner Erfahrung nach war der Netcup DNS bislang der letzte, der von den neuen DNS-Einträgen wusste. Beim letzten Mal hat die telekom nach 6 Stunden die neue Namen auflösen können aber auf dem Host selbst war die IP erst nach weiteren 15 Stunden verfügbar. Es war auch nicht das erste Mal, dass ich genau diese Erfahrung gemacht habe ... warum auch immer :P


    CU, Peter

  • ...Beim letzten Mal hat die telekom nach 6 Stunden die neue Namen auflösen können aber auf dem Host selbst war die IP erst nach weiteren 15 Stunden verfügbar.

    Hallo Peter,


    die Telekom war inzwischen doch recht schnell. Von meinem PC aus ist der Host auch per ping -6 erreichbar. Auf dem VPS selbst erhalte ich noch "unknown host", weiß jetzt aber Bescheid, dass ich noch etwas abwarten sollte.


    Das Verbinden auf den SMTP-Server per Mailclient mit IPv6-Adresse klappt jedoch immer noch nicht.