IPv6 einrichten (manuell, dhcp oder networkmanager)

  • Hallo zusammen,


    ich sitze seit paar Tagen immer mal wieder dran um meinen vserver mit IPv6 ins Netz zu bringen. Ich benutze http://www.crux.nu als Distribution, zu Hause kriegt sie via dhcp problemlos eine IPv6 und läuft. Leider nicht auf dem vserver. Der Kernel unterstützt IPv6.


    Ich habe zu erst im SCP unter Netzwerk eine IPv6 eingerichtet (aus dem mir zugewiesenen /64er Bereich die ::1) und mit meiner öffentlichen Domain verlinkt (genau wie es bei der ipv6 automatisch passiert war). Server habe ich dann auch das SCP ausgeschaltet und neu gestartet.


    Mein erster Versuch war die statische Einrichtung über iproute2. Hat leider nicht geklappt. Dort habe ich einiges probiert, was alles nicht zum gewünschten Erfolg führte.


    Heute Nacht habe ich mal den networkmanager installiert und den für eine statische Adressvergabe eingerichtet. Ebenfalls ohne Erfolg.:|


    Das liebste wäre mir, wenn jemand den richtigen Weg via iproute2 sagen könnte? Vielen Dank schon mal!


    Hier ein Output mit dem, was der networkmanager so macht:


    Viele Grüße,

    Tim

  • Code
    1. ping6 fe80::1%eth0

    Hast du einen DNS-Nameserver gesetzt unter /etc/resolv.conf ?

    Wenn du nur IPv6 benutzt, muss der Nameserver auch unter IPv6 erreichbar sein. z.B. 2001:4860:4860::8888 oder 2001:4860:4860::8844

    Das sind die Google Public DNS Server

  • H6G : Guter Einwand! Ja, hatte ich, der networkmanager hat se natürlich nur wieder alle entfernt....

    Allerdings sind sie unter nmcli und nmtui (der beiden Frontends für den NM) noch eingetragen, deswegen frage ich mich ob es daran liegen könnte. (Edit: nein, sie sind auch unter /etc/NetworkManager/system connections/x vorhanden)


    @ .A.: Danke, das wusste ich nicht!

    Der Output sieht so aus:

    Code
    1. tim@host:/home/tim$ ping6 -I eth0 google.de
    2. PING google.de(ams16s31-in-x03.1e100.net) from meine:IP:v6::1 eth0: 56 data bytes
    3. From meine.FQDN icmp_seq=1 Destination unreachable: Address unreachable
    4. From meine.FQDN icmp_seq=2 Destination unreachable: Address unreachable
    5. From meine.FQDN icmp_seq=3 Destination unreachable: Address unreachable

    Und mit ip -6 addr add 2001:DB8::1/64 dev ens3 hast du prinzipiell auch recht, das habe ich ebenfalls getan als ich es manuell gemacht hatte. Aber wie setze ich die korrekte Route auf fe80::1? Ich meine ich hatte sowas wie

    ip route add default via fe80::1 dev eth0

    probiert. Hatte nicht geklappt..

  • Also, jetzt hab ich es so probiert:


    ip -6 addr add IPv6::1/64 dev eth0

    ip -6 route add fe80::1 dev eth0

    ip -6 route add default via fe80::1 dev eth0


  • ip -6 addr add IPv6::1/64 dev eth0

    ip -6 route add fe80::1 dev eth0

    ip -6 route add default via fe80::1 dev eth0

    Lass die beiden letzten mal weg und leere zur Sicherheit mit ip -6 neigh flush dev eth0 den Cache. Dann müssten pings auf link local adresses funktionieren oder NDP ist defekt.

  • Im letzten ping command fehlt wieder der interface-Name.


    Hast du mal im Rettungssystem versucht IPv6 zu nutzen? Ich hatte mehrere Server, bei denen der Support erst noch was am routing reparieren musste.

    Current Servers

    morpheus: Root-Server M SSD v6a2
    apoc: VPS 50 G7
    link: Storage-Server S 1000 G7

  • Guten Tag TimB


    ich habe für Ihren Server gerade einmal eine kleine Änderung durchgeführt. Schalten Sie den Server bitte einmal komplett ab und wieder über das SCP ein. Dann sollte die IPv6-Konnektivität (vorausgesetzt, Sie haben die IPv6-Adresse korrekt statisch konfiguriert), gegeben sein.

  • Hi [netcup] Lars,


    danke! Es klappt! :)


    Code
    1. #ping6 -I eth0 google.de
    2. PING google.de(fra15s16-in-x03.1e100.net) from meine:IP:v6::1 eth0: 56 data bytes
    3. 64 bytes from fra15s16-in-x03.1e100.net: icmp_seq=1 ttl=59 time=853 ms
    4. 64 bytes from fra15s16-in-x03.1e100.net: icmp_seq=2 ttl=59 time=3.96 ms
    5. 64 bytes from fra15s16-in-x03.1e100.net: icmp_seq=3 ttl=59 time=3.94 ms
    6. 64 bytes from fra15s16-in-x03.1e100.net: icmp_seq=4 ttl=59 time=4.18 ms

    Danke auch an alle die Mitgeholfen haben!


    Ich nutze die statische Methode in Post #8 mit der route zu fe80::1


    Viele Grüße

    Tim