Probleme mit der installation von Easy-Wi

  • Wenn ich den Befehl ssh-keygen -t ed25519 -o -a 100 in ssh auf meinem Server eingebe dann bekomme ich ja 2 Dateien einmal eine id_ed25519 und eine id_ed25519.pub dann ist aber die Frage wie es genau weiter geht?

    Also was muss ich genau tun, ich frage das jetzt weil ich es sonst über Puttygen immer gemacht habe und dann einen Private key und einen public key hatte und den private key musste ich noch noch in Putty einfügen.

  • wenn du puttygen startest, dann hst du unten doch eine Auswahl, welcher Key erzeugt werden soll - steht bei standardmässig generiert werden soll. Insofern kannst du m.E. doch das gleiche Verfahren anwenden, wie bei deinem "alten" Key, oder nicht ?

    Gruss

  • ist dein Debian 9 nun Server oder Client ? Was hast du fuer einen Client ?

    ssh -vv brauchst du nicht in putty einzugeben - putty ist doch nur der Ersatz fuer ssh unter Windows (ok, gibts mittlerweile auch fuer Linux).


    Wenn Server = Debian9, dann sind die Loginversuche in /var/log/auth.log (sofern Standardkonfiguration)

    Gruss

  • Ich habe dir mal meine sshd_config als Anhang geschickt, ich habe nur diese Config bearbeitet und via SSH in /home/user einen .ssh Ordner erstellt und mit folgenden befehlen bearbeitet:


    touch .ssh/authorized_keys

    chmod 700 .ssh

    chmod 600 .ssh/authorized_keys

    chown -R test:test .ssh


    Ansonsten habe ich nichts verändert oder sonstiges, ich hoffe das hilft dir auch weiter. Und ja ich habe einen Rootserver und habe darauf Debian 9 installiert wenn du das meinst.

  • das stiftet mehr Verwirrung ...

    1. Server ist Debian 9, von dort hast du die /etc/ssh/sshd_config her attached

    2. dein Client ist vermutlich irgendein Windows, wenn du putty nutzt ?

    3. in der sshd_config ist das Logging ausgeschaltet - der Sinn erschliesst sich mir nicht

    4. oben schreibst du, dass du in /home/user einen .ssh Ordner erstellt hast: ist hier user==test ?

    5. wie sieht dein Login-Versuch aus (Protokolle ??) loggst du dich ein als test oder brandt

    6. wenn als User "test", wirds durch AllowUser geblockt, bzw AllowGroup

    7. wenn als brandt, dann duerfte der keine Rechte haben auf authorized_keys, g+o sollten Lese- aber keine Schreibrechte haben

    8. Protokolle waeren hilfreich :-) also Logging am Server erlauben (Restart sshd !) sowie auf putty logs - da kann dir im Moment nicht helfen, da aktuell kein WIn da ...

    Gruss

  • Das was du geschrieben hast verwirrt mich jetzt einwenig...


    Zu deinen Punkten:

    1. Debian 9 ist das Betriebssystem das ich installiert habe und die sshd_config ist aus etc/ssh/

    2. Was meinst du genau mit Client? Ich habe einen Linuxserver und nutze zum Steuern/Verwalten das Programm Putty.

    3. Wozu ist das Logging genau? Wie gesagt in der sshd_config sind die Dinge etwas anders aufgebaut als in Debian 8 (kann dir auch die Orginale sshd_config geben).

    4. Das war mein Fehler, da war ich etwas undeutlich in dem Verzeichnis home/brandt in dem Ordner brandt ist noch ein Ordner .ssh und dort ist der authorized_key.

    5. Momentan (ist ja klar) logge ich mich noch als root ein und "nach" der Absicherung wird/soll der root Zugang ja gesperrt werden und dann logge ich mich ausschließlich mit dem User brandt ein.

    6. Verwirrt mich etwas, wieso wird es "verhindert"? Ich dachte durch AllowUsers/AllowGroups wird ein User/eine Gruppe zugelassen und alles andere "geblockt"?

    7. Die Rechte für den User brandt habe ich mit usermod -aG ssh-manager brandt zugewiesen.

    8. Da verstehe ich nicht, was du mir sagen möchtest.


    MfG

  • Ich denke schon wenn ich folgendes mache:

    touch .ssh/authorized_keys

    chmod 700 .ssh

    chmod 600 .ssh/authorized_keys

    chown -R brandt:ssh-manager .ssh


    Oder nicht?


    Starte Putty mal bitte mit "-v" als Parameter.

    Meinst du damit dass ich mich bei Putty anmelden soll und dann -v eingeben soll?

  • Meinst du damit dass ich mich bei Putty anmelden soll und dann -v eingeben soll?


    Nein. Loxley spricht von Startparametern. Hier mal ne allgemeine Anleitung:

    https://www.tutonaut.de/anleit…mme-mit-optionen-starten/


    kurz: füge einer putty-Verknüpfung, der Anleitung folgend, einfach mal den Parameter -v hinzu.


    Scheinbar wird damit aber nur das Logging erweitert, jedoch nicht grundsätzlich aktiviert.

    Grundsätzlich aktivierst und konfigurierst du unter Windows (ich gehe mal davon aus, dass du Windows als CLient benutzt?) das Logging innerhalb von putty:

    https://www.thomas-krenn.com/de/wiki/PuTTY_für_Logging_konfigurieren

  • Na, dann stimmt wohl der Key, den Putty an den Server schickt nicht ;-)


    Wie hast du ihn denn erstellt? Du bist mit den Grundlegen von asymmetrischen Verschlüsselungsverfahren vertraut? => https://web-development.github.io/git/public-private-key/


    In Kürze: Es gibt zwei Schlüssel. Was der eine verschlüsselt, kann der andere entschlüsseln und andersrum. Einer davon wird als "privater Schlüssel" definiert, der bleibt bei dir und sollte geheim gehalten werden. Der zweite ist der "öffentliche Schlüssel" (pub/public). Den gibt man dem Kommunikationspartner. Wenn jetzt mit deinem privaten Schlüssel etwas verschlüsselt wird, kann der öffentliche Schlüssel das entschlüsseln, und weiß, dass die Botschaft von dir kam, weil nur du das machen konntest (vorausgesetzt, niemand anderes hat deinen privaten Schlüssel).


    Wie wird das jetzt bei SSH verwendet?

    Du erstellst auf deinem Rechner zu Hause ein Schlüsselpaar. Den öffentlichen Schlüssel kopierst du auf den Server in die "authorized_keys", also die Datei für vertrauenswürdige Schlüssel.

    Wenn du jetzt eine Verbindung mit Putty aufbaust, dann verschlüsselt Putty mit deinem privaten Schlüssel eine Botschaft und der Server schaut, ob er das mit einem der vertrauenswürdigen Schlüssel entschlüsseln kann. Geht das, lässt er dich rein.



    Wenn ich deinen Post oben richtig interpretiere hast du schon falsch rum angefangen, als du auf dem Server die Schlüssel erzeugt hast und nicht auf dem Client. "Theoretisch" ginge das auch, wenn du den erzeugten öffentlichen Schlüssel (.pub) zu den authorized hinzufügst, und den privaten auf deinen Rechner in Putty lädst. Praktisch wäre das dämlich, weil der Sinn von asymetrischer Verschlüsselung ist, dass der private Schlüssel gerade 'nicht' über das Internet transferiert wird.


    Ausführliche Anleitung:

    https://www.hrz.tu-darmstadt.d…ikel_details_22784.de.jsp

  • Ich habe es mal ausprobiert und hatte leider keinen Erfolg. Und eine Sache verstehe ich nicht ganz...


    Wieso habe ich es unter Debian 8 in unter 10Minuten (Bin Anfänger und habe ca. 10% Ahnung) geschafft die Public Key Authentifizierung zu erstellen (Die auch funktioniert hat) und bei Debian 9 nicht, das kann doch nicht war sein:cursing:

    Ich hoffe ihr habt irgendwelche anderen Tipps, wenn es hilft dass ich die sshd_config oder ssh_config (sind beide im Standard "zustand" da ich den Rootserver neu aufgesetzt habe, möchte erst den Rootserver absichern bevor ich irgendwas anderes mache) anhänge dann bitte bescheid geben.

  • Ich habe es mal ausprobiert und hatte leider keinen Erfolg.

    Mit dieser ausführlichen Fehlerbeschreibung kann ich leider nichts anfangen. Du schreibst, du hast den Rootserver neu aufgesetzt. Was hast du dann gemacht und was funktioniert nicht? Bist du nach einer Anleitung vorgegangen (welcher)?


    1) In Putty ein Schlüsselpaar erzeugen (siehe Link oben)

    2) Den Pubkey in deine authorized_keys file schreiben

    3) In der sshd_config: Public key aktivieren, Passwort Authentifizierung ausstellen

    4) SSHD daemon neu starten (service ssh restart)


    Wieso habe ich es unter Debian 8 in unter 10Minuten (Bin Anfänger und habe ca. 10% Ahnung) geschafft die Public Key Authentifizierung zu erstellen (Die auch funktioniert hat) und bei Debian 9 nicht, das kann doch nicht war sein:cursing:

    Debian 8 und 9 unterscheiden sich da nicht. Sieht nach klassischem PEBCAC aus ;)



    Was ich gerade noch sehe: Du willst einen anderen Nutzer verwenden (brandt?). Dann muss der Pubkey natürlich auch in die authorized keys des Nutzers brandt (/home/brandt/.ssh) und nicht in /root/.ssh. Den Nutzer muss es geben und bei Putty musst du diesen einstellen. Am besten stellst du erst mal den SSH auf den Nutzer "brandt" um (Nutzer anlegen, Root login im sshd deaktivieren). Wenn das funktioniert dann den Key-Zugang einrichten.

  • Mit dieser ausführlichen Fehlerbeschreibung kann ich leider nichts anfangen. Du schreibst, du hast den Rootserver neu aufgesetzt. Was hast du dann gemacht und was funktioniert nicht? Bist du nach einer Anleitung vorgegangen (welcher)?

    Sobald ich nach dem Loggin (in SSH) brandt eingebe und dann nach der Key-passphrase gefragt werde und die dann eingebe funktioniert sie nicht.

    Hast du da vllt. eine Idee?