Webseite von 'außen' erreichbar machen

  • Hallo zusammen!


    Ich bin bei netcup auf einem managed Server gezogen. Die Webseite die ich betreibe, basiert auf Wordpress.


    Nun erwartet ein Plugin, mit dem ich die Beiträge auf den Social Networks teile, das ich die Webseitenadresse ändere, da Beiträge von lokalen Installationen nicht auf den Networks gepostet werden.


    Problem dabei: Die angegebene Webadresse ist mit https://domain korrekt?


    Jemand eine Idee, wie ich da Abhilfe schaffen kann?

  • Das Plugin prüft wahrscheinlich, ob es selbst auf diese Adresse zugreifen kann. Vermutlich ist der loopback-Zugriff auf die eigene öffentliche IP-Adresse in der Firewall nicht erlaubt.


    Da kann maximal der Support helfen, da es ein Managed-Server ist. Die kennen ihr System auch am Besten und wissen sofort, ob es daran liegt. Schreib denen einfach eine kurze E-Mail.



    MfG Christian

  • Danke für die Antwort!


    Aber an den Support habe ich schon geschrieben, die konnten mir nicht helfen und haben aufs Forum verwiesen.


    Ich weiß mittlerweile aber, das es nicht an der Hardware liegt, da auf einem anderen Blog, der bei einem anderen (shared)-Hoster liegt, das gleiche Problem auftritt

  • Ist zwar jetzt nur eine Vermutung, aber evtl. arbeitet das Tool zur Prüfung mit dem RDNS Eintrag. Wenn dieser anders ist als deine Domain könnte es einen Fehler geben.
    Bei managed Servern kann diesen der Support ändern. Normal ist dieser v00000.yourpserver.net, lass diesen mal zum Testen gegen deine Domain austauschen.
    Ist aber nur eine Vermutung!

  • Bitte was soll der PTR-Record damit zu tun haben? :rolleyes:


    Marcus : Ja, von außen. Aber wahrscheinlich nicht vom gleichen System aus! Sprich: src 1.1.1.1 dst 1.1.1.1 (dev lo) » ist vermutlich geblockt. Schreib mal folgendes in eine PHP-Datei (z.B. test.php) und rufe sie über den Browser auf:


    PHP
    1. <?php
    2. ini_set('display_errors', '1'); error_reporting(-1);
    3. var_dump(file_get_contents('http://example.com/'));


    example.com musst Du gegen Die betroffene Domain, die am gleichen Server liegt, austauschen. Sollte dabei nichts oder nur eine Fehlermeldung ausgegeben werden, liege ich mit meiner Vermutung wahrscheinlich richtig.



    MfG Christian