MySQl Dienst startet nicht

  • Guten Tag


    Ich habe seit gestern das Problem, dass die MySQl Datenbank nicht mehr aufstartet.
    Auch mehrere restarts via

    Code
    1. sudo service mysql restart

    funktionieren nicht. Jedes Mal wird dieser Code ausgegeben:

    Code
    1. Job for mysql.service failed. See 'systemctl status mysql.service' and 'journalctl -xn' for details.


    systemctl status mysql.service:


    journalctl -xn:


    mysql-server habe ich schon versucht neu zu installieren mit:
    apt-get remove mysql-server
    apt-get install mysql-server
    Jedoch ohne Erfolg.

  • Nein... Hier die Datei /etc/mysql/my.cnf


  • Mein mysql wollte auch mal nicht starten (nach einen Server reboot) ^^
    Da musste ich laut anderen foren die Dateien /var/lib/mysql/ib_logfile0 und /var/lib/mysql/ib_logfile1 entfernen. (aufm PC "sichern" nicht vergessen ^^)
    dann lief es wieder problemlos.

    Du merkst, dass ein Bug an dir hoch krabbelt. Du findest ihn nett und nennst ihn Exploit.

  • Jetzt ist was ganz komisches passiert. Nach einem reboot ohne irgendwelche Änderungen startet nichts mehr. Also kein screen läuft und nicht mal SSH wird automatisch gestartet. Ebensowenig apache2. Ich muss jedes Mal nach einem Reboot wieder über die VNC Console service ssh start machen. Was läuft jetzt wieder falsch?

  • Du solltest da das Grundsystem unbedingt mal durchchecken, das klingt ziemlich suspekt...
    Wahrscheinlich funktioniert der mysqld aufgrund irgendeiner Kettenreaktion nicht mehr, die bei einer kürzlichen Änderung entstanden ist.

  • Schau dir mal das Tutorial hier an: Backup › MySQL › Wiki › ubuntuusers.de


    Kleiner Tipp: Bevor du den Server neu installierst solltest du schon vorher auf einem anderen Linux-System ein Restore der Daten versucht haben sodass du im besten Fall in das neue System die .sql-Datei importieren kannst.


    Falls du kein zweites System zur Hand hast würde ich dir VirtualBox empfehlen - einfach mal googlen, es gibt da ebenfalls tausende Tutorials

  • Also ich habe dies versucht doch ohne Erfolg...


    1. service mysql stop
    2. neues /var/lib/mysql löschen
    3. altes /var/lib/mysql einfügen
    4. chown -R mysql:mysql /var/lib/mysql/
    5. service mysql start


    Da stand dann nur, dass man nicht auf die Datenbank zugreiffen kann... auch als root nicht. Mache ich da noch was grundsätzlich falsch? Muss ich noch Konfigurationsdateien wiederherstellen?

  • Nun habe ich auf meinem Windows Computer MySQL Server 5.7.10 und Workbench installiert. Dann habe ich alle Datenabnken sowie auch ib_logfile0, ib_logfile1 und ibdata1 in das \data\ Verzeichniss verschoben. Dann wollte ich den Server mit "C:\Program Files\MySQL\MySQL Server 5.7\bin\mysqld" starten, doch ohne Erfolg. Es hat folgenden Error gegeben:



    Da steht was von upgrate, doch die Seite MySQL :: MySQL 5.7 Reference Manual :: 2.11.1 Upgrading MySQL hilft da nicht weiter, da mysql_upgrate nicht geht, da der Server gar nicht läuft. Was kann ich dagegen tun?

  • Du solltest einen MySQL Server <5.7 nutzen, da es anscheinnen Probleme damit gibt. Also am besten die Version die du genutzt hast.

    Gut das habe ich gemacht... Und auch wieder load_corrupted auf 1 gestellt. Nun gibt es folgenden Fehler beim Aufstarten:



    Was kann ich dagegen tun? Aber ich denke du hast mich weiter gebracht redhell

  • Moin,


    ich bezweifel dass es die gleiche Version war. Vermutlich ist die aktuelle Version nun zu alt bzw. es gibt versionsunterschiede zwischen Windows und Linux. Mach dir bitte eine VM mit genau den gleichen Versionen, da ist die Erfolgswahrscheinlichkeit am höchsten ;)


    PS: Sind das wieder die Originaldaten vom Server oder die gleichen, die du schonmal unter Windows versucht hast?

  • Moin,


    ich bezweifel dass es die gleiche Version war. Vermutlich ist die aktuelle Version nun zu alt bzw. es gibt versionsunterschiede zwischen Windows und Linux. Mach dir bitte eine VM mit genau den gleichen Versionen, da ist die Erfolgswahrscheinlichkeit am höchsten ;)


    PS: Sind das wieder die Originaldaten vom Server oder die gleichen, die du schonmal unter Windows versucht hast?

    Auf dem Server war 5.5.44 installiert (eine Beta) und jetzt habe ich auf Windows die 5.5.44 MariaDB installiert. Das sollte gleich sein. Und ja es sind wieder die gleichen Daten auf Windows. Hier habe ich was gefunden: mysql - InnoDB: Error: log file ./ib_logfile0 is of different size - Server Fault nur... wo ist diese Config Datei?


    EDIT: Ist es die my.ini und wenn ja... was muss ich da verändern?
    EDIT2: Gut ich habe jetzt innodb_log_file_size zu 5MB gesetzt. Nun startet MySQLd, doch sobald ich eine Tabelle ansehen will steht da:

    Code
    1. Error Code: 1146. Table 'mcplayhd.banlist' doesn't exist


    EDIT3: Dies steht dazu in der .err Datei:

    Code
    1. 151226 11:28:19 [ERROR] Cannot find or open table mcplayhd/banlist from
    2. the internal data dictionary of InnoDB though the .frm file for the
    3. table exists. Maybe you have deleted and recreated InnoDB data
    4. files but have forgotten to delete the corresponding .frm files
    5. of InnoDB tables, or you have moved .frm files to another database?
    6. or, the table contains indexes that this version of the engine
    7. doesn't support.
    8. See http://dev.mysql.com/doc/refman/5.5/en/innodb-troubleshooting.html
    9. how you can resolve the problem.