Nach Update von Wheezy zu Jessie melden alle Domains 403 Forbidden

  • Hallo,


    ich habe heute morgen meinen vServer von Wheezy zu Jessie (Debian 8.0) upgedated.


    Nach dem Neustart melden jetzt leider alle dort gehosteten Domains : 403 Forbidden .

    Bisher geprüft:

    - Standard Server Seite über http://IP wird angezeigt
    - SSH Login ist möglich
    - Froxlor Login ist möglich
    - phpmyadmin Login möglich

    Bisherige Google Ergebnisse deuten auf evtl auf eine verbogene apache2.conf (oder deren Unter-Varianten) hin.
    Ich kann aber da nicht Falsches erkennen.
    In der .conf selbst wird schon "Require all granted" verwendet.

    Für alle sachdienlichen Hinweise sehr dankbar
    golive






  • libnss-mysql-bg, das Froxlor verwendet, gibt es in Jessie nicht mehr. Mit dem Paket wurden die Daten aus mysql gelesen und an die jeweiligen Dienste weitergeben.


    Wenn du Froxlor nutzen willst, musst du warten oder ne sourcelist von whezzy nehmen und libnss-mysql-bg nachinstallieren und entsprechend der Anleitung in Froxlor konfigurieren.


    Bitte berichte, ob das klappt.

  • Hallo zusammen,


    ich kann berichten, dass ein Update des von Netcup angebotenen Pakets "Debian Wheezy + Froxlor" auf Debian Jessie funktioniert.


    Das Update selbst sollte wie folgt durchgeführt werden:

    Code
    1. apt-get update
    2. apt-get upgrade
    3. apt-get dist-upgrade


    Danach in

    Code
    1. /etc/apt/sources.list

    alles von "wheezy" in "jessie" umbenennen:

    Code
    1. sed -i 's/wheezy/jessie/g' /etc/apt/sources.list


    Im Anschluss wieder wie folge das upgrade der Pakete durchführen:

    Code
    1. apt-get update
    2. apt-get upgrade
    3. apt-get dist-upgrade



    Das oben beschriebene Problem mit den im Froxlor angelegten Webseiten kann leicht durch eine Einstellung im Froxlor selbst behoben werden:
    (Hat mit der neuen Version von Apache 2.4 anstatt 2.2 in Debian Jessie zu tun)


    - Als Admin im Froxlor anmelden und die Seite "Server / Settings" aufrufen
    - Unter "Web Server settings" den Button "Settings wählen
    - Auf der Settings-Seite für den Apache die Checkbox "Use modifications for Apache 2.4" auswählen und speichern
    - Im Menü "Server / Rebuild config files" aufrufen und bestätigen
    - Nachdem das Cron-Script von froxlor gelaufen ist sollten die Webseiten wieder funktionieren


    Wer ungeduldig ist, kann natürlich auch kurz das Cron-Script manuell auf der console triggern:

    Code
    1. /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --tasks --force



    Hoffe das hilf ein paar Update-willigen :)


    Schönen Feiertag,
    Michael

  • Herr Minni,
    danke für die anleitung. bei mir startete der apache nicht mehr und die seite xxx.xxxx.xxx.xxx/froxlor wurde nicht gestartet


    nach dem ich in /etc/apache2/apache2.conf

    Code
    1. LockFile ${APACHE_LOCK_DIR}/accept.lock



    mit


    Code
    1. Mutex file:${APACHE_LOCK_DIR} Default


    ersetzt habe hat es nun geklappt.