Froxlor kompatibilität? oder was mach ich falsch?

  • Mein System: Ubuntu 12.04.04 LTS
    Froxlor 0.9.31.2



    Systemdetails


    Webserver: Apache/2.2.22 (Ubuntu)
    PHP-Version: 5.3.10-1ubuntu3.9
    MySQL Server Version: 5.5.35-0ubuntu0.12.04.1
    Webserver-Interface: APACHE2HANDLER
    System-Auslastung: 0.00 / 0.01 / 0.05
    Kernel: 3.8.0-35-generic (x86_64)



    Froxlor-Details
    Backup Cronjob: Bisher nicht gestartet
    Berechnung der Mailbox-Größen: Bisher nicht gestartet
    Erstellen von Konfigurationsdateien: Bisher nicht gestartet
    Archivieren alter Tickets: 25.01.2014 01:00:00
    Traffic-Berechnung: 25.01.2014 00:00:00
    Webspace- und Trafficreport: Bisher nicht gestartet
    Zurücksetzen der Ticket-Zähler: 25.01.2014 01:00:00
    Installierte Version: 0.9.31.2



    Ich habe Froxlor so installiert in dem ich es einfach in /var/www/froxlor
    gepackt habe und halt mit 00.my.ip.00/froxlor aufgerufen habe und die config datei erstellt und verschoben habe.
    des weiteren habe ich alle die unteren punkte an Konfiguration gemacht


    Ubuntu12.04 (Precise)


    Webserver(HTTP)
    Apache 2
    Nameserver(DNS)
    NIX
    Mailserver(SMTP)
    Postfix/Dovecot
    Mailserver(IMAP/POP3)
    Dovecot
    FTP-Server
    NIX
    Sonstige(System) Crond (cronscript)
    Awstats
    libnss-bg (system
    login with mysql)
    Logrotate


    mein Problem ist jetzt das Froxlor keine datei in sites-available von Apache 2 anlegt?
    obwohl ich einen Kunden und ihn eine Domain zugewiesen habe.
    und
    Erstellen von Konfigurationsdateien ist immer auf Bisher nicht gestartet.
    was wahrscheinlich mein Problem erklärt


    ich habe die "Sonstige (systeme)" 2 mal Installiert und editiert.
    was kann ich jetzt noch tun oder was habe ich Falsch gemacht? ohhh man. ich werde gleich verdruckt :D



    Vielen danke im voraus leute.

  • Wie man in den Froxlor-Details sieht wurde der Cronjob noch nie ausgeführt und daher auch keine Konfigurationsdateien erstellt. Hast du "Sonstiges" - "Crond (cronscript)" korrekt durchgeführt? (Hinweise beachten!)


    Du kannst denCronjob ja auch mal manuell anstoßen und schauen was passiert:
    /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --force

  • Okay habe mit dem Befehl der untern steht froxlor an gestupst und er hat auch Dateien angelegt unter anderem in /etc/apache2/sites-enabled
    Die Seite wird auch richtig angesteuert mit dem Browser
    aber müssen die nicht für Virtuel Host in sites-available?


    aber den Cron job macht der automatisch nicht!!! achhhhh Froxlor


    Kann das sein das Froxlor nicht kompatibel ist mit 12.04.04?


    hier par Infos
    Ubuntu 12.04.4 LTS (GNU/Linux 3.8.0-35-generic x86_64)


    mit dem Befehl kommt sowas
    /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --force

    Code
    1. mkdir: das Verzeichnis »/etc/bind/domains/“ kann nicht angelegt werden: Datei oder Verzeichnis nicht gefunden
    2. PHP Warning: fopen(/etc/bind/domains/***********.com.zone): failed to open stream: No such file or directory in /var/www/froxlor/scripts/jobs/cron_tasks.inc.dns.10.bind.php on line 99
    3. PHP Warning: fwrite() expects parameter 1 to be resource, boolean given in /var/www/froxlor/scripts/jobs/cron_tasks.inc.dns.10.bind.php on line 100
    4. PHP Warning: fclose() expects parameter 1 to be resource, boolean given in /var/www/froxlor/scripts/jobs/cron_tasks.inc.dns.10.bind.php on line 101
    5. PHP Warning: fopen(/etc/bind/froxlor_bind.conf): failed to open stream: No such file or directory in /var/www/froxlor/scripts/jobs/cron_tasks.inc.dns.10.bind.php on line 138
    6. PHP Warning: fwrite() expects parameter 1 to be resource, boolean given in /var/www/froxlor/scripts/jobs/cron_tasks.inc.dns.10.bind.php on line 139
    7. PHP Warning: fclose() expects parameter 1 to be resource, boolean given in /var/www/froxlor/scripts/jobs/cron_tasks.inc.dns.10.bind.php on line 140
    8. sh: 1: /etc/init.d/bind9: not found
    9. sh: 1: /usr/local/bin/webalizer: not found


    Hier nochmal was ich in den Konfiguration steht hatte und gemacht habe!
    der obere Befehl seht etwas anders aus aber ist der so richtig in der
    /etc/cron.d/froxlor


    Sonstige (System) » Crond (cronscript)

    Code
    1. /etc/cron.d/froxlor
    2. #
    3. # Set PATH, otherwise restart-scripts won't find start-stop-daemon
    4. #
    5. PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
    6. #
    7. # Regular cron jobs for the froxlor package
    8. #
    9. */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php


    Sonstige (System) » Awstats

    Code
    1. apt-get install awstats
    2. cp /usr/share/awstats/tools/awstats_buildstaticpages.pl /usr/bin/
    3. mv /etc/awstats/awstats.conf /etc/awstats/awstats.model.conf
    4. sed -i.bak 's/^DirData/# DirData/' /etc/awstats/awstats.model.conf
    5. # Please make sure you deactivate awstats own cronjob as Froxlor handles that itself
    6. rm /etc/cron.d/awstats


    Sonstige (System) » Logrotate

    Code
    1. # apt automatically adds a daily cronjob for logrotate
    2. # you do not have to do anything else :)


    ich bin doch nicht der erste mit dem Problem da muss es doch eine Lösung geben. *Froxlor mich sehr traurig machen. :(kann ich ein älter Froxlor ver. nehmen
    danke für die Hilfe

  • Ich habe Froxlor nicht selbst installiert da ich das von netcup erstelle image nutze:


    Meine Seiten werden auch alle nur in sites-enabled gelistet, passt also so.


    Dass Froxlor seinen Job nicht machen kann, wenn es nicht per Cronjob aufgerufen wird, dafür kann es nichts.


    In meiner /etc/cron.d/froxlor steht die Zeile wie folgt:
    */5 * * * * root /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php


    /etc/init.d/cron restart
    hast du ausgeführt?


    Ein älteres Froxlor zu nehmen macht keinen Sinn, da geht eher weniger als mehr.


    In Sachen Kompatibilität am besten die Entwickler in IRC fragen oder das Froxlor Wiki besuchen.

  • Okay habe mit dem Befehl der untern steht froxlor an gestupst und er hat auch Dateien angelegt unter anderem in /etc/apache2/sites-enabled
    Die Seite wird auch richtig angesteuert mit dem Browser
    aber müssen die nicht für Virtuel Host in sites-available?


    vHosts in sites-available werden gar nicht geladen, dann sie sind - wie der Ordnername verrät - nur verfügbar aber nicht aktiviert. ;)


    Zu den Fehlermeldungen mit bind: Ist bind überhaupt installiert? Wenn nicht, können die Konfigurationsdateien natürlich nicht beschrieben werden, da gar nicht vorhanden.

  • Okay ich habe wirklich alles ausprobiert, aber warum macht der cron seinen Job nicht


    Daten Rechte sind richtig root root und 644 oder muss es 754 sein.?


    Was kann ich machen das Cron geht?


    Hat jemand hier Ubuntu 12.04.04 LTS mit Froxlor drauf was geht?


    geht das nur mit Debian oder was???


    also mit dem Befehl



    /usr/bin/php5 -q
    /var/www/froxlor/scripts/froxlor_master_cronjob.php --force
    geht es aber immer wenn was anliegt den Befehl ausfuhren
    ist nicht im sine des Machers.

  • okay habe das halbe Problem gefunden!!!


    crontab -e geht mit eingetragenen Befehl super!!!
    man muss nur drauf achten das in der datei ganz untern #------------------ steht!!
    also eine ausgeklammerte Zeile (warum auch immer mit Leerzeile wie ist in manchen tuts steht geht es nicht)


    Code
    1. #-----------------------------------------------------------------
    2. # Shell variable for cron
    3. SHELL=/bin/bash
    4. # PATH variable for cron
    5. PATH=/usr/local/bin:/usr/local/sbin:/sbin:/usr/sbin:/bin:/usr/bin:/usr/bin/X11
    6. #M S T M W Befehl
    7. # m h dom mon dow Befehl
    8. #-----------------------------------------------------------------
    9. */5 * * * * echo Test Froxlor stinkt alle 5min | wall
    10. #-----------------------------------------------------------------


    ja gut die datei /etc/cron.d/froxlor dann dem entsprechend geändert
    und im syslog seht es auch ganz gut aus jetzt keine syntaxfehler oder bad time oder sonstiger Mist von froxlor


    Code
    1. Jan 29 11:43:01 superserver cron[787]: (*system*froxlor) RELOAD (/etc/cron.d/froxlor)
    2. Jan 29 11:44:08 superserver cron[1885]: (CRON) INFO (pidfile fd = 3)
    3. Jan 29 11:44:08 superserver cron[1886]: (CRON) STARTUP (fork ok)
    4. Jan 29 11:44:08 superserver cron[1886]: (CRON) INFO (Skipping @reboot jobs -- not system startup)
    5. Jan 29 11:45:01 superserver CRON[2033]: (root) CMD (/usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php^M)
    6. Jan 29 11:45:01 superserver postfix/postdrop[2037]: warning: unable to look up public/pickup: No such file or directory
    7. Jan 29 11:50:01 superserver CRON[2044]: (root) CMD (/usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php^M)
    8. Jan 29 11:50:01 superserver postfix/postdrop[2048]: warning: unable to look up public/pickup: No such file or directory


    außer den pickup warning aber auch das ist schnell gegessen

    Code
    1. # mkfifo /var/spool/postfix/public/pickup
    2. # /etc/init.d/postfix restart


    so jetzt geht der cron job immer noch nicht......... zweite Hälfte des Problems
    und wo war das Problem? in Froxlor selbst
    in der Konfiguration gibt Froxlor an die datei /etc/cron.d/froxlor so zu bearbeiten


    # ist nicht der ganze code!!! nur das wichtige!!!

    Code
    1. */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php
    2. #-----------------------------------------------------------------


    aber es muss so sein

    Code
    1. */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php
    2. #-----------------------------------------------------------------


    und wer sieht es ......
    besser seht man es in der Konsole mit cat -v /etc/cron.d/froxlor
    und wer weiß es,,,,,, wer weiß es????


    !!!!ein Leer Zeichen!!!!!
    GENAU!!!


    also Leute so löst man Probleme. :D hat spaß gemacht
    aber was mich wundert das muss doch Froxlor selbst wissen das das Müll ist was sie da gebaut haben. keiner wir denken das es an ein Leerzeichen liegt
    man zerbricht sich den scheiß Kopf und denkt es liegt am System oder an einem selbst.
    aber es liegt an denn Leute bei Froxlor


    Bitte den Titel ändern in :D
    Froxlor kompatibilität? oder was macht Froxlor falsch :D? cron.d geht nicht. Cronjob startet nicht
    bitte. :D


    und hier für Froxlor könnt ihr so übernehmen



    Konfigurationsdateien: Bitte ändern Sie die entsprechenden Konfigurationsdateien
    oder legen sie mit dem folgenden Inhalt neu an, falls sie nicht existieren.
    Bitte beachten Sie: Das MySQL-Passwort wurde aus Sicherheitsgründen nicht ersetzt.
    Bitte ersetzen Sie "MYSQL_PASSWORD" manuell durch das entsprechende Passwort.
    Falls Sie es vergessen haben sollten, finden Sie es in der Datei "lib/userdata.inc.php".
    /etc/cron.d/froxlor


    Code
    1. #
    2. # Set PATH, otherwise restart-scripts won't find start-stop-daemon
    3. #
    4. PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
    5. #
    6. # Regular cron jobs for the froxlor package
    7. #
    8. */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php
    9. #----------------------------------------------------------


    Bitte vergewissern sie sich das hinter dem Befehl des Cronjobs ein Leerzeichen befindet!!!
    ***froxlor_master_cronjob.php@
    des "@" zeichen soll das Leerzeichen symbolisieren.



    Neustart: Bitte führen Sie die folgenden Kommandos zum Neuladen
    der Konfigurationsdateien in einer Shell aus.


    Code
    1. /etc/init.d/cron restart
    2. # nicht das Leerzeichen vergessen!!!



    zur Verteidigung von Froxlor im Englischen haben sie es richtig drin also bug schnell raus machen und am ende ausklammern.


    Ich wünche euch einen schönnen tag!!!