Linux vServer auf KVM-Server umziehen

  • Moin,
    Ich habe es einfach mal versucht, ob es nicht geht einen bestehenden Linux-vServer 1:1 auf die neuen KVM-Server zu migrieren. Nach etwas herumprobieren hat es auch geklappt - erstaunlicherweise sehr gut, ich hatte mit mehr Problemen gerechnet ;-)
    Ich habe es mal zusammengeschrieben, bis jetzt läuft auch alles so wie es soll (Mail, Webserver, SQL...):
    http://www.johnassel.de/blog/?p=2767
    Vielleicht hilft es ja dem ein oder anderen.



    Jonas

  • Einige Schritte dabei sind auch überflüssig.


    Es reicht beim KVM-Server mit einer beliebigen Live-CD zu booten, die Festplatten zu partitionieren und dann kann man einfach per rsync/ssh vom alten System alle Daten übernehmen.

  • johnassel


    Danke für die Anleitung, hat einwandfrei geklappt bei mir! Hat mir einiges an Arbeit erspart.


    Allerdings hab ich noch ein Problem mit dem Netzwerk, das startet nicht automatisch beim reboot.


    Was muss ich da nochmal genau machen, ist etwas schlecht beschrieben in der Anleitung.


    Ich muss nach jedem reboot über die VNC Console ein "ifup eth0" ausführen, dann läuft es.

  • Ich hatte die die /etc/network/interfaces nur auf DHCP umgestellt (hatte ich vorher statisch)


    und dann mit "service networking off" und "service networking on" den Netzwerkdienst wieder auf automatischen Start gestellt, danach kamen auch die Netzwerkinterfaces beim Reboot wieder hoch.

  • Das hatte ich versucht.


    Muss morgen noch mal probieren.


    Es geht übrigens auch mit dem normalen Rescuesystem von netcup. Ist nicht readonly, hätte ja dann auch nicht viel Sinn das Rescuesystem wenn man was reparieren muss... Bzw. hab ich da /dev/volume/root@ anstatt /dev/vda1 nach /vserver gemountet.

  • Okay, im Prinzip also vereinfacht:
    1.) KVM Server ordern (Hab bereits die zweite Mail von netcup das ich das doch machen sollte :D)
    2.) KVM Server mit einem Rescue/Live OS booten & partitionieren
    3.) alten vServer ebenso in ein Rescue/Live OS booten
    4.) den alten vServer mittels rsync/ssh auf den neuen KVM Server klonen
    5.) in die geklonte Maschine mittels chroot wechseln (vorher natürlich das wichtigste mounten)
    6.) grub installieren, networking anpassen, ggf richtigen Kernel vom OS installieren
    7.) Das neue System booten, Domains auf die neuen IPs zeigen lassen - ggf postfix transport vom alten auf den neuen server einrichten


    was vergessen?


    Kann man irgendwo/wie die TTL Zeiten der Domains kurzzeitig ändern damit der IP-Switch nicht ewig dauert?

  • Also nochmal zu dem Problem mit dem Networking.


    Habe es eben nochmal versucht:


    Code
    1. root@srv1:~# service networking on
    2. Usage: /etc/init.d/networking {start|stop}


    also: "/etc/init.d/networking start" Das läuft ohne Fehlermeldung, aber das Netzwerk wird nicht gestartet. (ifconfig zeigt nur lo).


    Habe jetzt erstmal "ifup eth0" in die rc.local eingetragen, so startet das Netzwerk wenigstens bei einem automatischen reboot von alleine, wenn auch erst ganz am schluss...


    Weiss jemand was hier falsch läuft?


  • Habe den Fehler gefunden.


    in der /etc/network/interfaces hat noch "auto eth0" gefehlt.


    So funktioniert es nun:



    Der Hinweis kam von hier: Debian Squeeze Netzwerkeinstellungen übernehmen | MeyJu Blog

  • just4info


    System von vServer zu KVM geklont - läuft wunderbar weiter.


    Durchgeführte Schritte:


    Beide Server mit den normalen Rettungssystemen gebootet.
    Auf dem KVM Server das vorinstallierte System mittels fdisk ins Nirvana geschickt (ich brauchte davon keinerlei Dateien).
    Mittels fdisk eine neue Partitionierung vorgenommen (/boot, /, swap).
    Partitionen mit ext4 formatiert und in eigenes Verzeichnis gemounted (/boot nicht vergessen!).
    Das alte System via SCP & tar einfach rüber kopiert (man muss nur /dev auslassen, der rest ist eh leer...).
    chroot Umgebung vorbereitet (--bind von proc, dev & sys)
    chroot auf das alte, geklonte system
    > folgende schritte werden alle im "chroot" durchgeführt) <
    Eigenen kernel installiert (ich hab den 3.2er aus den debian backports genommen).
    grub2 installiert (/dev/vda).
    /etc/network/interfaces angepasst
    /etc/udev/rules.d/ - die "Network" Datei gelöscht (wird neu angelegt, die muss nur weg wegen der geänderten mac-addr)
    >reboot<
    Kiste läuft!
    Bei den Domains noch die neue IP eingetragen und fertsch..


    Wunderbar!

  • bRunO, für Linux vServer musstest du schon an diversen Stellen mit Workarounds arbeiten. Wie bekommst du die wieder sauber aus dem System raus? KVM kannst du ja wie jede beliebige echte Hardware ansehen, du brauchst keine extra Treiber, etc. Klonen per rsync sollte klappen, habe ich mit realen Systemen auch schon mehrfach gemacht. Aber nach über 5 Jahren möchte man auch mal Systeme komplett neu aufsetzen ,-)

  • vmk ,


    was für Workarounds? ich hab unter debian keine Workarounds gebraucht - also musste ich da auch nichts entfernen - wie in Beitrag #13 schon geschrieben hab ich lediglich einen eigenen Kernel installiert


    klonen per rsync ist letztendlich nichts anders als wenn ich mittels SCP in beiden Rettungsystemen die Daten spiegel!
    Ich will nicht von rsync abraten, aber rsync war bei mir zumindest in einem der Rettungssystemen nicht vorhanden so das ich auf die SCP Variante zurückgreifen musste.


    TPIT-Service , mein Beitrag #13 ist eine grobe Anleitung - den Rest findest du mittels google.