Ping geht nicht mehr (Temporary failure in name resolution)

  • Sieht so aus als hättest du dir (oder irgendein update) irgendwann die netzwerk config zerschossen, und das hat sich dann halt erst nach dem reboot / neustart des networking service bemerkbar gemacht.


    du kannst ja einen db-dump anlegen und den per rettungssystem runterladen.


    kenne mich mit netplan leider null aus (nutze nur debian 10 und centos), da müssen dir andere leute weiterhelfen.


    es ist leider so, dass wenn es im rettungssystem geht, zwangsläufig dein system „schuld“ ist und der netcup support dir daher nicht helfen wird.

  • Sieht so aus als hättest du dir (oder irgendein update) irgendwann die netzwerk config zerschossen, und das hat sich dann halt erst nach dem reboot / neustart des networking service bemerkbar gemacht.


    du kannst ja einen db-dump anlegen und den per rettungssystem runterladen.


    kenne mich mit netplan leider null aus (nutze nur debian 10 und centos), da müssen dir andere leute weiterhelfen.


    es ist leider so, dass wenn es im rettungssystem geht, zwangsläufig dein system „schuld“ ist und der netcup support dir daher nicht helfen wird.

    hm ja verstehe ich auch... aber ich blicke einfach nicht was da schief gelaufen ist.


    Klar ich kann das jetzt neu Installieren. Aber das ist ja grad mal 1 Monat alt... ich hab den Server seit einem Monat und bin von einem Anbieter hier her wegen anderen Problemen und kaum/schlechten Support.


    Ich hab nur nginx und mysql installiert und python halt, aber halt nichts am netzwerk oder sowas geändert, weil das ja sowieso funktionierte alles bis zum restart

  • hm ja verstehe ich auch... aber ich blicke einfach nicht was da schief gelaufen ist.


    Klar ich kann das jetzt neu Installieren. Aber das ist ja grad mal 1 Monat alt... ich hab den Server seit einem Monat und bin von einem Anbieter hier her wegen anderen Problemen und kaum/schlechten Support.


    Ich hab nur nginx und mysql installiert und python halt, aber halt nichts am netzwerk oder sowas geändert, weil das ja sowieso funktionierte alles bis zum restart

    Wie gesagt ich kann dir da nicht akut helfen, nur folgenden Tipp geben: leg einen Snapshot vor größeren Systemänderungen an und mach einen Reboot sobald du etwas grundlegendes geändert hast. Dann bemerkst du etwaige Fehler derart sofort und nicht erst Wochen später.


    hier sind bestimmt genug Leute die dir weiterhelfen können und deine Netzwerk-Config fixen können, aber ich gehöre leider nicht dazu, ich wage mich gerade mal an die /etc/networking/interfaces dran - von Ubuntu lasse ich (gerade wegen netplan) bewusst die Finger :D:(

  • Kannst du mal auch einen Screen von der Konfiguration aus diesem Ordner schicken "/etc/network/interfaces.d/".


    Man kann auch bei Ubuntu ohne Netplan konfigurieren. Ich hab eine Maschine mit Ubuntu die bisher ohne Netplan konfiguriert ist.

    Des weiteren kannst du auch mal schauen ob du unter /etc/init.d/ mit Tabben irgendwas mit Networking findest.

  • Wie gesagt ich kann dir da nicht akut helfen, nur folgenden Tipp geben: leg einen Snapshot vor größeren Systemänderungen an und mach einen Reboot sobald du etwas grundlegendes geändert hast. Dann bemerkst du etwaige Fehler derart sofort und nicht erst Wochen später.


    hier sind bestimmt genug Leute die dir weiterhelfen können und deine Netzwerk-Config fixen können, aber ich gehöre leider nicht dazu, ich wage mich gerade mal an die /etc/networking/interfaces dran - von Ubuntu lasse ich (gerade wegen netplan) bewusst die Finger :D:(

    Hm dann hoffe ich mal das ich jemanden finde der mir helfen kann :(

    Hoffe morgen sind vielleicht noch andere da, die das Network wieder fixen können... hab halt nix geändert und jetzt alles neu machen uff...

  • Kannst du mal auch einen Screen von der Konfiguration aus diesem Ordner schicken "/etc/network/interfaces.d/".


    Man kann auch bei Ubuntu ohne Netplan konfigurieren. Ich hab eine Maschine mit Ubuntu die bisher ohne Netplan konfiguriert ist.

    Des weiteren kannst du auch mal schauen ob du unter /etc/init.d/ mit Tabben irgendwas mit Networking findest.

    Den Ordner "/etc/network/interfaces.d/" gibt es bei mir gar nicht... in /etc/network ist nur if-pre-up.d/ und if-up.d/ sowie interfaces


    netplan (also als Command) gibt es bei mir auch nicht. Der sagt immer ich kanns über apt installieren (command not found)


    in /etc/ gibt es mit net... folgende Begriffe:

    netplan/, network/ und networkd-dispatcher/

  • Warte mal - bei „apt“ kommt „command not found“?!


    Wenn ja hast du dein System irgendwie - auf deutsch gesagt - komplett geschrottet. Ich würde die DB per Rettungssystem runterladen und komplett neu installieren.


    EDIT: sorry, habs falsch verstanden, du meintest wohl dass „netplan“ nicht gefunden wird und nicht „apt“

  • Ich meinte eher sowas wie /etc/init.d/networking

  • Ich würde an deiner Stelle folgendes machen:


    Da dein System ja aktuell eh nicht erreichbar ist empfehle ich nochmal: zieh ein DB-Dump, lad das per Rettungssystem herunter und installier den Server per ISO neu und importier danach den DB-Dump.


    Das erklärt zwar nicht was passiert ist, aber das geht sicherlich schneller als bis morgen zu warten bis einer der netplan-Kenner dir eine Lösung bietet.


    EDIT: du kannst auch einen (offline!-)snapshot vor der Neuinstallation anlegen um jederzeit zum status quo zurückwechseln zu können.

  • Ich würde an deiner Stelle folgendes machen:


    Da dein System ja aktuell eh nicht erreichbar ist empfehle ich nochmal: zieh ein DB-Dump, lad das per Rettungssystem herunter und installier den Server per ISO neu und importier danach den DB-Dump.


    Das erklärt zwar nicht was passiert ist, aber das geht sicherlich schneller als bis morgen zu warten bis einer der netplan-Kenner dir eine Lösung bietet.


    EDIT: du kannst auch einen (offline!-)snapshot vor der Neuinstallation anlegen um jederzeit zum status quo zurückwechseln zu können.

    Problem ist, bis ich raus habe wie ich die Datenbank im SQL als Backup ziehe usw... ist halt auch morgen abend :(

    Abgesehen davon das die Datenbank Millionen Einträge hat. Das ist halt mein Problem :/ Wäre das nicht viel oder alles klein und wenig Infos, hätte ich das längst einfach neu installiert

  • Also ein dump Kannst du wie folgt erstellen:

    Code
    1. mysqldump -u<username> -p<passwort> <datenbankname> > <dateiname.sql>

    Im Rettungssystem hast du dann die Möglichkeit die Festplatte des Servers zu mounten und die .sql-Datei dann wo anderster Zwischenspeichern. Wenn du hierfür keinen anderen Server order Speichermöglichkeit hast, kannst du mich gerne per PN anschreiben und ich kann dir für die Kurze Zeit etwas anbieten.


    Ich bin nämlich auch Ubuntu und netplan angeht auch am Ende. Vorallem da

  • Marcel R. du verwirrst die Leute.

    Er nutzt Ubuntu 20, da gibt es weder SysV-Init (sprich /etc/init.d), noch die Netzconfig über /etc/network/interfaces, sondern über netplan


    Das Interface ist als Down markiert.


    "Internet" kannst du dir so herbeizaubern um Netplan o.ä. zu installieren:

    Code
    1. ip a add 123.123.123.254/22 dev eth0
    2. ip link set dev eth0 up
    3. ip r add default via 123.123.123.1 dev eth0

    123.123.123.254/22 ist deine Server IPv4 samt Subnetzmaske

    123.123.123.1 ist das Gateway von Netcup