Eigener Nameserver CCP

  • Ahoi zusammen,

    wir betreiben einen Root Server bei Netcup und unsere Domains sind auch bei Netcup.

    Ein DNS ist der Plesk DNS und neuerdings haben wir auch noch einen zweiten (anderer Server bei Netcup).


    Die Denic kennt unsere beiden Nameserver. NAST Prüfung erfolgreich, siehe Screenshot.

    Screenshot_2020-12-05 NAST - DENIC eG(1).png

    Im CCP sehe ich unter DNS an der Doamin GAR NICHTS mehr. Quasi nichts eingetragen.


    Wenn ich die Nameserver angeben will bekomme ich folgende Meldung (auch bei anderen Domains):

    Screenshot_2020-12-05 netcup ccp(4).png

    Das wollte ich angeben:

    Screenshot_2020-12-05 netcup ccp(3).png


    Die Fehlermeldung bekomme ich bei jeder Domain die ich routen will. Ich bin zwar kein Hardcore Nerd, hatte aber nie derartige Probleme bei diversen Hostern.

    Woran könnte es liegen? Wird da irgendwas gecached oder so?


    Danke & Grüße Christian

  • Inconsistent Nameservers deutet darauf hin, dass Dein NS1 und NS2 nicht dieselbe SOA (Serial) ausliefern.


    domain=meindomainname.de; nameserverdomain for i in ns1 ns2; do echo -en "${i}.${nameserverdomain}; "dig +short @${i}.${nameserverdomain} -t SOA ${domainname}; done


    Diese Einzeiler-Schleife sollte hinter dem Doppelpunkt jeweils identisch sein.


  • domain=meindomainname.de; nameserverdomain for i in ns1 ns2; do echo -en "${i}.${nameserverdomain}; "dig +short @${i}.${nameserverdomain} -t SOA ${domainname}; done


    Diese Einzeiler-Schleife sollte hinter dem Doppelpunkt jeweils identisch sein.

    Danke dir, wie gesagt, ich bin kein Hardcore Nerd. Putty sagt jedenfall Syntax Fehler.


    Wenn die Seriennummern nicht stimmen würden, würde der NAST doch fehlschalgen oder?

  • Hallo Christian,

    laut deinem Screenshot hast du die Felder Hostname, IPv4-Adresse und IPv6-Adresse ausgefüllt. Das ist bei netcup etwas irreführend gemacht. Die Spalten IPv4-Adresse und IPv6-Adresse dürfen nur dann ausgefüllt werden, wenn sich der Hostname der DNS Server innerhalb der jeweiligen Domain befindet (Glue-Record).


    In deinem Fall konkret: deine DNS Server sind in der Zone joho-broiler.de, also darfst du nur dann die beiden hinteren Spalten ausfüllen, wenn die Domain, deren Nameserver du gerade festlegen willst joho-broiler.de ist. Bei allen anderen Domains darfst du nur die erste Spalte "Hostname" ausfüllen.


    Hoffe das hilft dir weiter :-)

  • ... also darfst du nur dann die beiden hinteren Spalten ausfüllen, wenn die Domain, deren Nameserver du gerade festlegen willst joho-broiler.de ist

    Hy marpi, genau so ist es. Die Domain deren Nameserver ich gerade festlegen will ist joho-broiler.de


    Von ns1 ist die ipv4 der Server und die IPv6 ist dem joho-broiler webspace zugeordnet. Anbei noch ein Screenshot vom DNS. Vielleicht entdeckt ihr da was merkwürdiges.

    Screenshot_2020-12-05 Der Plesk DNS-Server fungiert als primärer Name Server der DNS-Zone joho-broiler de - Plesk Obsidian [...].png

  • Von ns1 ist die ipv4 der Server und die IPv6 ist dem joho-broiler webspace zugeordnet. Anbei noch ein Screenshot vom DNS. Vielleicht entdeckt ihr da was merkwürdiges.

    ???

    Die IPv4 und die IPv6 von ns1 und ns2 sollten auf einen Rechner lauten, auf dem je ein Nameserver auf Port 53 UDP antwortet (Mindesterfordernis). Die ausgelieferten Zonen müssen identisch sein.

    https://de.wikipedia.org/wiki/Domain_Name_System#Nameserver


    Ein dig -t soa auf Deine Domain mit den 2 IPv4 und 2 IPv6-Adressen liefert jedenfalls eine SOA. Es mag Geschmackssache sein, aber ich verwende dort für die hostmaster-E-Mailadresse nichts, was einen Punkt "\." erfordern würde, sondern schlicht hostmaster@domain.tld.

  • Moin @ all,

    ???

    Die IPv4 und die IPv6 von ns1 und ns2 sollten auf einen Rechner lauten, auf dem je ein Nameserver auf Port 53 UDP antwortet (Mindesterfordernis). Die ausgelieferten Zonen müssen identisch sein.

    https://de.wikipedia.org/wiki/Domain_Name_System#Nameserver

    So sollte es theoretisch auch sein. NS2 ist der Slave und bekommt die Zonefiles von NS1.


    Ein dig -t soa auf Deine Domain mit den 2 IPv4 und 2 IPv6-Adressen liefert jedenfalls eine SOA. Es mag Geschmackssache sein, aber ich verwende dort für die hostmaster-E-Mailadresse nichts, was einen Punkt "\." erfordern würde, sondern schlicht hostmaster@domain.tld.

    Ich hab die Mailadresse mal geändert. Danke für den Hinweis.


    Es stellt sich mir aber immernoch die Frage warum Netcup das nicht akzeptiert.


    Ein fröhlichen Nikolaus euch allen,

    Grüße Christian

  • Glue-Records sind leider immer wieder ein Problem. Existieren sie bereits, und man trägt sie anlässlich eines Transfers neu ein, passiert beizeiten so etwas, wie bei Dir.


    Denkbare Workarounds:

    A) cloudflare o.ä. nützen,

    B) A und AAAA Deiner Nameserver in einer anderen Deiner Domains nützen und wechselseitig verwenden

    C) He.net (IPv6-Broker) bietet Secondary NS kostenlos an - hiermit eventuell einen hidden Master bauen?

    D) Billigst-Domains mit unterschiedlichen Endungen für je einen Nameserver verwenden.


    All die Workarounds B+C haben mir bei einer .at über das Wochenende nichts geholfen, weil beim Eintrag der eigenen Nameserver nach anfänglich anderer Fehlermeldung ein von netcup generiertes Whois-Object die Übernahme des Nameserversets verhindert hat.


    Ich hoffe, Du hast mehr Glück!

  • Glue-Records sind leider immer wieder ein Problem. Existieren sie bereits, und man trägt sie anlässlich eines Transfers neu ein, passiert beizeiten so etwas, wie bei Dir

    Bei Netcup oder was? Ich bin leicht genervt. :)

    Ich hoffe das der Support sich endlich mal äussert. Seit Donnerstag warte ich auf ne Sinnvolle Antwort.