glue-records für Mail-in-a-Box

  • Hi.


    Ich möchte auf einem kleinen vserver Mail-in-a-Box installieren. Dazu sollen eigene nameserver eingetragen werden. Das findet sich ja recht schnell im CCP. Vorher sollen allerdings glue-records gesetzt werden und auch genau darüber gibt es im CCP eine Fehlermeldung. Direkte glue-record Einstellungen wie in einigen Online Tutorials beschrieben finde ich bei netcup nicht aber hier im Forum habe ich an der ein oder anderen Stelle gelesen, dass man die glue-records bei den DNS Einstellungen der Domain eintragen kann. Nur wie genau - das habe ich nicht gefunden oder übersehen. Kann mir dazu jemand Hilfestellung geben?


    -Danke & Gruß

    ...

  • Ja das habe ich gesehen. Bevor ich die eigenen Nameserver eintragen kann, soll ich allerdings glue-records erstellen. Dazu steht in der Wiki nur:

    Glue Records

    Liegt ein Nameserver in der gleichen Zone wie die Domain, muss ein Glue Record gesetzt werden. Dabei handelt es sich um die IP-Adresse des Nameservers, die zum Hostnamen zusätzlich angegeben wird. Beim Speichern wird geprüft ob der Nameserver die Domain verwaltet.


    Nur - wie setzt man die? Vielleicht bin ich auch einfach nur begriffsstutzig. Wo gebe ich denn die IP "zusätzlich" zum Hostnamen an? Wenn ich die eigenen Nameserver eintrage: ns1.box.domain.tld bzw. ns2... dann bekomme ich nach ein paar Sekunden eine Fehlermeldung:


    IP des Nameserver ns1.box.domain.tld im falschen Format. Bitte geben Sie die IP des Nameservers als IPv4 oder IPv6 an.

    Da der Nameservereintrag innerhalb der bearbeiteten Zone liegt, muss eine IP zum Nameserver angegeben werden (Glue record).

    Bisher habe ich den rDNS Eintrag zu box.domain.tld gemacht und auch den hostname dazu geändert.

  • Wenn ich das mache, dann bekomme ich die Fehlermeldung (siehe oben).


    Also ich muss einen glue-record Eintrag machen, bevor ich den netcup nameserver auf eigene nameserver umstelle. Da trage ich die ns1.box.domain.tld und ns2.box.domain.tld ein und dazu die IPv4 IPs. Das sieht man ja auch in dem Screenshot in der Wiki. Und wenn ich das mache, dann bekomme ich die Fehlermeldung.


    Hat jemand hier schon mal eine Mail in a Box unter netcup zum laufen bekommen?


    Ich habe heute mit einem Freund (ITler) ein paar Gameserver konfiguriert und ihn da auch mal drauf schauen lassen. Wir haben nicht viel Zeit damit verbracht aber er meinte, dass er es so versteht, dass netcup überprüft ob der eigene nameserver Eintrag auch auf einen nameserver verweist. Nameserver ist bei der IP natürlich nicht hinterlegt, da es ja ein frisches minimal Image ist.


    Stehe auf dem Schlauch. Kann ja auch sein, dass MiaB mit der Domain bei netcup nicht geht. Dann schaue ich mir andere Lösungen an.

  • Du meinst diese Fehlermeldung?


    IP des Nameserver ns1.box.domain.tld im falschen Format. Bitte geben Sie die IP des Nameservers als IPv4 oder IPv6 an.


    Sind die beiden Nameserver korrekt autoritativ für die Zone box.domain.tld konfiguriert und antworten?
    Ist die Schreibweise der IPv4 und/oder IPv6 korrekt? Gerade bei IPv6 gibt es da ja mehrere Varianten - hier meine Settings mit IPv4 + IPv6 Glue-Records:


    2020-05-13 20_50_55-netcup ccp und 3 weitere Seiten - Gunnar – Microsoft​ Edge.png

  • Ich habe viel zu kompliziert gedacht. Es fehlte aber auch von MiaB der dezente Hinweis, dass man die Installation abschließen muss, damit man die eigenen nameserver eintragen kann. Jetzt läuft alles. Danke für die Hinweise.


    Wie hast du das mit dem DNSSEC Eintrag gelöst (falls du es gemacht hast)? Nachdem die eigenen nameserver eingetragen sind, gibt es hier ja keine Option mehr irgendwelche Eintragungen zu machen.

  • Ich habe viel zu kompliziert gedacht. Es fehlte aber auch von MiaB der dezente Hinweis, dass man die Installation abschließen muss, damit man die eigenen nameserver eintragen kann. Jetzt läuft alles. Danke für die Hinweise

    Da muss ich mal nachfragen, was mit "Installation abschließen" gemeint ist. Ich habe eine MiaB laufen und eine zuvor - vor dem Domain-Umzug zu Netcup - gab es mit den externen (MiaB-)Nameservern keine Probleme. Bei Netcup enden die Versuche, diese zu verwenden mit den Fehlermeldungen:

    Code
    1. Die Nameserver konnten nicht aktualisiert werden. Domain update at registrar failed. 53300102912: Nameserver error
    2. ERROR 106 Inconsistent set of nameserver IP addresses (NS, provided glues, determined glues) (ns1. ...

    Da bin ich jetzt ratlos, weil MiaB ja ordentlich läuft ...

  • Ein Satz oben war ja versehentlich unsinnig formuliert ... was ich meinte, ist:

    MiaB war konfiguriert mit einer Domain, die dann von einem anderen Hoster zu Netcup umzog. Hier versuchte ich dann (ebenso) die Nameserver von MiaB als externe einzutragen, endet aber eben mit obiger Fehlermeldung.


    Ob das eine Frage der Zeit ist, bis sich irgendwelche Werte (Serial?) weltweit eingestellt haben? Oder eben ...?