google search console: Seite mit Weiterleitung

  • Hallo,

    auf einem netcup-Server habe ich Ubuntu als Server installiert und dort RocketChat in einem Snap-Container eingerichtet. Da RocketChat üblicherweise auf Port 3000 läuft und ich außerdem https erzwingen will, habe ich nginx als Reverse Proxy installiert und konfiguriert. Die Funktion ist voll gegeben.

    Leider verweigert mir Google die Indexierung meiner Webseite. Der URL-Test ergibt: Ausschluss wegen Seite mit Weiterleitung.

    Hier der Inhalt meiner RocketChat.conf:


    Automatische Weiterleitung auf https:
    server {

    listen 80;

    server_name xxxxx.de;

    rewrite ^ https://$server_name$request_uri?permanent;

    }


    Alternativ vergeblich getestet (Funktion ok aber google will auch hier nicht):

    server {

    listen 80;

    server_name xxxxx.de;

    return 301 https://$server_name$request_uri;

    }


    Mein letzter Test hat gezeigt, dass die Weiterleitung zu https auch ohne die beiden obigen Blöcke funktioniert.

    Wie geht das denn:?:


    Hier die interne Weiterleitung zum Rocketchat auf Port 3000:

    server {

    listen 443 ssl;

    server_name chat4free-fun.de;

    error_log /var/log/nginx/rocket.error.log;

    ssl_certificate /etc/nginx/ssl/xxxxx.crt;

    ssl_certificate_key /etc/nginx/ssl/xxxxx.key;


    location / {

    proxy_set_header X-Real-IP $remote_addr;

    proxy_set_header X-Forward-For $proxy_add_x_forwarded_for;

    proxy_set_header Host $http_host;

    proxy_set_header X-Nginx-Proxy true;

    proxy_pass http://127.0.0.1:3000;

    proxy_redirect off;

    }

    }


    Hat jemand eine Idee warum Google meine Seite nicht in ihren Index aufnimmt bzw. welchen Fehler ich hier mache:?:

    Wie gesagt, funktionieren tut alles, nur Google will nicht.


    Viele Grüße

    Ricki

  • Hi,

    im Normalfall sollte man eine Weiterleitung auf https immer über die zweite Lösung mit Statuscode 301 lösen. Das ist dann SEO konform.


    Aktuell leitet deine Seite garnicht weiter und verwendet zudem auch ein ungültiges SSL Cert. Das solltest du erstmal prüfen.


    Mein letzter Test hat gezeigt, dass die Weiterleitung zu https auch ohne die beiden obigen Blöcke funktioniert.

    Wie geht das denn

    Indem sich dein Browser merkt, dass da https ging und es automatisch wieder nutzt. Ein anderer Browser, der die Seite nicht kennt, wird anders reagieren. ;)

    Das ist der krux. Die Weiterleitung muss garnicht funktionieren - aber in deinem Browser schauts so aus. Teste sowas am besten mit curl.



    //EDIT:

    für Configs bitte in Zukunft Code Blöcke nutzen - das verbessert die Leserlichkeit! ;)

    RS Rentier 2019 | CX11-CEPH | CX21 | CPX11


    Wer im Netz Anstand und Respekt verliert, der ist auch im realen Leben für nichts zu gebrauchen! ;)