SSH Verbinden mit Windows oder Putty führt zu connection timeout.

  • Hallo,

    ich habe mir vor kurzem einen vServer bestellt.

    Ich würde mich gerne mit einem SSH Client darauf verbinden, leider reagiert sowohl der ssh client von windows 10 als auch von putty

    mit einem Connection time out.

    Verbunden habe ich mich über root@hostname -p 22.

    Über den SCP komme ich auf den Server, der SSH dienst läuft auch. (Habe über ssh localhost -p 22, den Dienst getestet).

    Ich habe dann einen Online-SSH-Server-Verbindungstest gemacht um zu schauen ob denn der Server von außen erreichbar ist und das hatte auch funktioniert.


    Es scheint also ein Problem mit meinem Client/Rechner zu sein. Hat jemand eine Ahnung, woran es noch liegen könnte?

    Oder welche Schritte ich gehen könnte um näheres herauszufinden?


    Viele Grüße

  • Sicherlich ist ein root-Login per ssh deaktiviert.


    Was konkret sagt der Windows SSH Client als Fehlermeldung? Mach mal bitte ein 'ssh -v server' und poste dann hier die Ausgabe. Deinen Servernnamen kannst du raus'xxx'en.


    @friend_of_root: winSCP != ServerControlPanel

  • Naja, eigentlich Connection time out != Time out.

    Vielleicht hilft dem Treadersteller dieses hier: https://superuser.com/question…-doesnt-work-but-ssh-does

    Es geht immer noch nicht um SCP.


    JonDoe klappt die Verbindung wenn du die IP anstatt des Hostnamens nutzt? Wenn ja -> DNS-Caching

    ChestSort: Automatische Kistensortierung in Minecraft - www.chestsort.de


    binichblau: Online-Promillerechner - www.binichblau.de

  • Es geht immer noch nicht um SCP.

    Ok, sehe ich mittlerweile auch. ;)

    Habe immer geschaut "Über SCP komme ich auf den Server, der SSH dienst läuft auch."
    anstatt "Über den SCP komme ich auf den Server, der SSH dienst läuft auch."


    In dem Fall tippe ich auch auf root-Login per ssh deaktiviert, oder Firewall nicht geöffnet für Port 22.

  • Danke für die schnellen Rückmeldungen.


    Leider komme ich erst heute Nacht nach Hause an, also habe ich mal an meinem Arbeits-PC nochmal versucht eine Verbindung aufzubauen. Allerdings weiß ich nicht ob da die Firewall vllt zwischen funkt.


    vmk

    ssh -v root@xxxxx liefert:


    debug1: Reading configuration data /etc/ssh/ssh_config

    debug1: /etc/ssh/ssh_config line 58: Applying options for *

    debug1: Connecting to xxxxx [xxxxx] port 22.

    debug1: connect to address xxxxx port 22: Connection timed out

    ssh: connect to host xxxxx port 22: Connection timed out


    mfnalex Leider funktionierts auch mit IP-Adresse nicht.


    Ich hab mit netcat mal versucht den Port zu scannen seltsamer weise liefert er mir auch ein connection timed out.


    nc -zv xxxxx 22 liefert:

    Ncat: Version xxxxx ( https://nmap.org/ncat )

    Ncat: Connection timed out.


    Für netcat scheint also der Port geschlossen zu sein.


    Über sshcheck.com habe ich allerdings mal einen Check durchgeführt und der liefert mir dann prima die ganzen Daten zu dem remote Dienst auf Port 22. Mit public keys die verwendet werden und alles. Das heißt SSH-check ist zumindest bis zum Handshake gekommen. Also kann der Port gar nicht geschlossen sein.

  • vmk

    Also ich hab auf meinem Server noch nichts installiert außer wine. Deshalb müssten es die Standardeinstellungen sein. Fail2Ban ist auch nicht drauf.

    Hab mal

    "iptables --list-rules" verwendet und dies gab folgendes aus:


    -P INPUT ACCEPT

    -P FORWARD ACCEPT

    -P OUTPUT ACCEPT


    ich schätze das heißt, dass dort noch keine Regeln auf die Chains angewendet wurden.


    Caspar

    Auf den Server komme ich über den VNC ohne Probleme. Ich kann den server auch über den webbrowser erreichen.


    Traceroute liefert:


    traceroute to ***** (*****), 30 hops max, 60 byte packets

    1 192.***** (192.*****) 0.531 ms 0.624 ms 0.850 ms

    2 ***** (*****) 3.727 ms 3.687 ms 3.026 ms

    3 ***** (*****) 3.142 ms 3.769 ms 3.786 ms

    4 ***** (*****) 3.063 ms 3.735 ms 3.049 ms

    5 f-ed11-i.f.de.net.dtag.de (62.154.15.162) 12.509 ms 11.482 ms 11.814 ms

    6 gw-dtag.fra.netcup.net (80.157.204.242) 17.618 ms 17.058 ms 17.030 ms

    7 meine-adresse (meine-ip) 14.821 ms 13.270 ms 13.115 ms



    alhazred

    Firewall habe ich eigl schon überprüft. Ansonsten würde ich das heute Abend nochmal abchecken ggf. von nem Linuxrechner oder so nochmal ne Verbindung zum remote Server aufbauen.



    Auf dem vServer habe ich mir mal

    auth.log angeschaut und sehe gerade, dass ich vollgespammt werde mit SSH-login versuchen. Kann es vielleicht daran liegen, dass mein SSH dienst überfordert ist und deshalb nicht mehr auf meine Versuche reagiert?


    Wenn ja, was sollte ich tun?

  • Moin,


    ich kann mir nicht vorstellen das der ssh Daemon derart überfordert ist, aber versuchen kann man es ja mal.


    Code
    1. vi /etc/ssh/sshd_config


    Die Angabe hinter "Port" auf einen möglichst hohen Port z.B. 32222 ändern.


    Danach noch den ssh Daemon neustarten.


    Mich würde auch mal die Ausgabe von folgendem Befehl auf deinem Server interessieren :


    Code
    1. ss -tulpen | grep ssh
  • Caspar

    Hab den Port geändert. Auf dem Client dann ssh root@ip-adresse -p 32222 eingegeben. Leider auch Time-out.

    Also wahrscheinlich doch nicht wegen überlastung...


    Bezüglich der ss - tulpen Ausgabe:

    tcp LISTEN 0 128 *:32222 *:* users:(("sshd",pid=9352,fd=3)) ino:97629 sk:000

    00009 <->

    tcp LISTEN 0 128 :::32222 :::* users:(("sshd",pid=9352,fd=4)) ino:97631 sk:000
    00014 <->

  • Hey JohnDoe,


    hast du die Ausgabe verändert?

    Also * eingesetzt?


    Poste doch mal die Ausgabe von


    Code
    1. ip a


    Vergleich die Ausgabe deiner IP Adressen mit denen die dir im SCP angezeigt werden, stimmen die überein?


    Geht vom Server ein :


    Code
    1. ping google.de
  • Leider komme ich erst heute Nacht nach Hause an, also habe ich mal an meinem Arbeits-PC nochmal versucht eine Verbindung aufzubauen. Allerdings weiß ich nicht ob da die Firewall vllt zwischen funkt.


    In Firmen ist es oft so, dass für Arbeitsplätze ausgehend nur HTTP(S) via Firmenproxy erlaubt ist. Also gehe davon aus, dass du vom Arbeitsplatz aus kein SSH machen kannst. Workaround für später: https://github.com/shellinabox/shellinabox

  • Caspar

    Ne die Ausgabe habe ich unbeeinflusst angegeben.


    Die Ausgabe von "ip a" ergab:


    1: lo: <LOOPBACK,UP;LOWERUP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1

    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

    inet 127.0.0.1/8 scope host lo

    valid_lft forever preferred_lft forever

    inet6 ::1/128 scope host

    valid_lft forever preferred_lft forever


    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000

    link/ether 2a:7d:da:6b:ea:23 brd ff:ff:ff:ff:ff:ff

    inet [meine-ip-adresse]/22 brd [eine-aehnliche-ip-adresse] scope global eth0

    valid_lft forever preferred_lft forever

    inet6 [adresse-mit-identischen-network-prefix]/64 scope global deprecated

    valid_lft forever preferred_lft forever

    inet6 [irgendeine-ipv6-adresse]/64 scope link

    valid_lft forever preferred_lft forever


    Im SCP wird meine ipv6 nur mit den ersten 4 Doppelpunktstellen angezeigt. Deshalb weiß ich nicht ob die angezeigte ipv6 adresse identisch ist mit der vom SCP. I


    Ach ja der ping an google funktioniert auch.


    vmk Danke für den Link.


    Würdet ihr mir empfehlen mich mit dem Support oder so auseinandersetzen?

  • Ne, aktuell würde ich vorschlagen das du verifizierst das das nicht an deinem Zugang liegt.


    Wie vmk schon angedeutet hat, kann es auch gut sein das da einfach was blockiert ist.


    Versuch dein Glück von einem anderen Internet Zugang aus, oder bitte jemanden für dich zu prüfen ob der SSH Dienst erreichbar ist.


    Wenn sicher ist, das es nicht an deinem Zugang liegt, dann wirst du dich trotzdem erstmal damit auseinander setzen müssen das das Problem nicht irgendwo an deiner Konfiguration liegt.

    Denn der Support sollte erst dann zum Greifen kommen wenn die beiden Faktoren sicher ausgeschlossen sind.

    :)

  • Hast du ein Smartphone? Du könntest hier einen beliebigen SSH-Client installieren und damit dann über mehrere Netze (Mobilfunk, verschiedene WLAN) testen.

  • So das Problem ist gelöst.

    Ich hatte glücklicherweise einen Dual-Boot auf meinem Home Rechner und hatte von meiner Linux Partition eine SSH Verbindung gestartet. Und es hat geklappt.


    Daraufhin bin ich auf meiner Windows Partition nochmal alle Programme durchgegangen die was mit Netzwerkzeugs zu tun hatten und habe bemerkt, dass ich noch nen VPN-Client installiert hatte der eine eigene Firewall verwaltet. Hab den Client testweise deinstalliert und jetzt funktionierts auch mit PuTTy.


    Puh, das nenn ich eine Geburt :D