Upload Speed Root Server

  • Hallo,


    Bevor ich an den Support schreibe die Frage hier im Forum. Habe zu Testzwecken auf meinem RS G8 (Debian 10) apt get speedtest-cli installiert und etliche Server probiert. Download bis zu 800 Mbit, Upload bei keinem einzigen Server über 4,5 MBit.

    Der Server macht zur Zeit gar nichts (keine CPU, IO Last).

    Auch ein Download direkt via WinSCP gibt nicht mehr her. Ist jetzt sicher schon eine Stunde lang so...


    Ist das irgendwie erklärbar:?:

  • Das Tool ist jetzt nicht gerade dafür bekannt, die richtigen Ergebnisse zu produzieren.

    Ich würde dir empfehlen mit iperf3 einmal gegen einen Server auf dieser Liste zu testen: https://iperf.fr/iperf-servers.php


    Dann würde ich gerne noch wissen, wie du IPv4 und IPv6 auf deinem System konfiguriert hast (statisch, dynamisch) und welchen Netzwerktreiber du im SCP eingestellt hast.


    Was auch helfen würde ist, wenn du mal das Rettungssystem startest und da deine Tests durchführst.

  • Hi,

    Danke für den Hinweis. Habe iperf3 verwendet, das geht um einiges besser ;-)


    Habe dann auch noch einen Beitrag hier im Forum gefunden, dürfte ein Problem mit dem speedtest-cli in Debian sein.

    IPv4 ist statisch, IPv6 gar nicht

    Treiber: VirtIO


    Komisch ist nur, dass ich auch mit WinSCP keine besondere Geschwindigkeit schaffe, aber das liegt u.U. auch am WinSCP, muss ich noch testen

  • Komisch ist nur, dass ich auch mit WinSCP keine besondere Geschwindigkeit schaffe, aber das liegt u.U. auch am WinSCP, muss ich noch testen

    Welches Protokoll verwendest du denn da? (FTP oder SCP oder SFTP)

    Wie hoch ist deine Internetgeschwindigkeit zu Hause, über welchen Provider gehst du, hast du evtl. CG-NAT?

    Evtl. sieht es ja unter IPv6 besser aus, wenn du auch IPv6 bei dir am Internetanschluss hast.

  • geekmonkey und H6G : Danke für eure Rückmeldungen, ich war leider ein paar Tage außer Gefecht.

    Wie schon geschrieben, die Werte mit iperf sind OK, bug im Speetest client.


    Wg. WinSCP: Man sollte den Unterschied zwischen Megabyte und Megabit beachten ;-) WinSCP gibt das in Megabyte an, daher meine Verwirrung...

  • Retrieving speedtest.net configuration...

    Testing from netcup GmbH xxx.xxx.xxx.xxx)...

    Retrieving speedtest.net server list...

    Selecting best server based on ping...

    Hosted by Gemeindewerke Nümbrecht GmbH (Nümbrecht) [143.00 km]: 11.114 ms

    Testing download speed................................................................................

    Download: 552.25 Mbit/s

    Testing upload speed................................................................................................

    Upload: 402.23 Mbit/s

  • sla : NW Karte ist auf virtio, qemu-guest-agent installiert (keine ahnung, ob das eine Auswirkung auf den speed hat, vermutlich nicht)

    Ryker : Welche Version hat dein speedtestclient? ich bin auf Debian 10, da ist es 2.0.2-1, wie schon geschrieben, habe in Foren gefunden, dass es damit Probleme gibt.
    Habe testweise
    curl -Lo speedtest-cli https://raw.githubusercontent.com/sivel/speedtest-cli/master/speedtest.py

    chmod +x speedtest-cli

    das aktuelle Skript geladen, mit dem schauen die Werte besser aus

  • Natürlich haben falsche/fehlende Treiber Auswirkungen auf die Performance. Dabei ist es egal ob es um Netzwerkkarten, Grafikkarten oder was auch immer geht. in deinem Fall ist ja alles korrekt eingestellt. Das herumtasten ist auch nicht das gelbe vom Ei. Man sollte immer bedenken das es bei TCP einen Overhead gibt im Gegensatz zu UDP, weiterhin sollte man bedenken das SCP eine verschlüsselte Übertragung ist und auch hier kaum die angegebene Bruttodatenrate erreicht wird.


    Mein persönlicher Lieblingstest ist der wget auf ein File. Gibt diverse File Download Speedtests. Einfach mal suchen. Hier ist es eine einfache TCP Connection, das eigentlich meistbenutzte Real Life Szenario. Alternativ tut es auch Curl. Hiermit hast du Praxisnahe werte, einen Cronjob einrichten für das wget, alle Stunde laufen lassen und in ein Log schreiben lassen, per Mail schicken lassen. Wenn man das mal ein paar Tage beobachtet hat kann man daran herauslesen ob es mit Lastspitzen zusammenhängt oder nicht. Es gibt ja auch noch andere User auf dem Host, vielleicht beansprucht da jemand viel Bandbreite. Dann sollte Netcup optimieren.


    In den Cron sollte man noch einen aktuellen System Report einbauen, so hat man Bandbreite und Systemlast in einem und kann das mal genauer Anschauen.