Proxmox auf RS 1000 + extra IP

  • Hi!

    Ich habe einen RS 1000 mit Debian Stretch laufen und Proxmox installiert. Ich habe mir auch schon eine zweite IP bestellt und auch schon freigeschalten bekommen. Nun will ich eine VM auf Proxmox laufen haben die von ausserhalb über diese IP erreichbar ist.
    Ich habe mir auch schon diverse Posts im Forum angeschaut aber diese haben mir leider nicht weitergeholfen.
    Kann mir hier bitte jemand dabei helfen das zu konfigurieren?

    Vielen Dank schonmal vorab.

  • wenn ich mich versuche mit ssh (ssh rfnx@188.68.44.X) auf der VM anzumelden verbindet er sich auf den host und nicht auf den guest.

    hier beide Kofigurationen:

    host:

    auto lo

    iface lo inet loopback

    iface eth0 inet manual

    auto vmbr0

    iface vmbr0 inet manual

            bridge-ports none

            bridge-stp off

            bridge-fd 0

    source /etc/network/interfaces.d/*


    guest


    proxmox.png


    Danke ;)

  • @nfnalex

    Eine IP Addresse hat er, ich erreiche ihn zumindest über SSH, sollte die auch in der interfaces stehen?
    und wie weise ich einen bridge port zu?



    m_ueberall


    Momentan läuft die vm in einem LXC Container, habe schon das VMX Flag angefragt, aber 2 EUR monatlich zu zahlen für ein simples BIOS setting ist mir dann auf Dauer irgendwie doch leider etwas zu teuer ;)


    Danke

  • Ist die Geschäftspolitik von netcup aber auch deutlich mehr als nur ein "BIOS Setting". Kann man jetzt gut finden oder nicht.


    Die IP-Adresse müsste in /etc/network/interfaces stehen oder in einem File unter /etc/network/interfaces.d.

  • Hin oder her, momentan kann ich mir das nicht leisten, denke aber eine eimalige Zahlung wäre ausreichend. Und noch setze ich den Server nicht gewinnbringend ein. Und noch reicht ein LXC Container für die VM für meine Zwecke ;)


    Das steht sie natürlich auch:


  • Wenn du die Netzwerkkarte außerhalb der Bridge konfiguriert hast, braucht die Bridge eine generische Adresse, z.B. 172.31.1.1/32. Auf dem PVE Host muss auch eine Route geschaltet sein, damit der Server weiß, dass er diese IP annehmen darf: ip r a ZUSATZ-IP dev vmbr0


    Im Container trägst du dann die ZUSATZ-IP/32 ein und als Gateway 172.31.1.1.


    Wenn du die Netzwerkkarte innerhalb der Bridge konfiguriert hast, braucht die Bridge die Hauptadresse. Die Hauptadresse ist dann ebenfalls das Gateway für den Container.


    Zum Debuggen kannst du ping und tcpdump auf dem Host verwenden tcpdump -nni vmbr0 icmp oder tcpdump -nni eth0 icmp. Ebenfalls könntest du gucken, dass die Firewall offen ist.


    sysctl -w net.ipv6.conf.all.forwarding=1

    sysctl -w net.ipv4.ip_forward=1

    Nicht vergessen!

  • habe alles nochmal überprüft und komme immernoch nicht drauf:


    VM neu aufgesetzt, sie hat aber keinen internetzugang, mit dieser config:

    pasted-from-clipboard.png:


    auf Proxmox ist die Bridge gesetzt;
    pasted-from-clipboard.png

    Auf dem host schaut die Netzwerkkarte so aus:


    /etc/network/interfaces

    /etc/network/interfaces.d/50-cloud-init.cfg

    Was mache ich hier falsch?

  • Der Container hätte die CIDR 32 und als Gateway die Adresse der vmbr0.

    Das hier:

    Code
    1. auto eth0:2
    2. iface eth0:2 inet static
    3. address 188.68.44.XXX/32

    muss weg. Stattdessen eine Route einrichten.


    Nameserver werden durch resolv.conf gestellt und nicht in der Interface Definition.

    Versuch bitte mal die Netzwerkconfig in ein File zu mergen.