fail2ban ssmtp - keine mails

  • Hey Leute, kann mir wer sagen, warum fail2ban via ssmtp keine mails raushaut?


    hab in der jail.local schon alles porbiert:


    Code
    1. # Sender email address used solely for some actions
    2. sender = root@localhost 
    3. oder
    4. sender = mail@domain.de
    5. oder
    6. sender = alias@domain.de
    7. mta = sendmail
    8. action = %(action_mwl)s


    Hier mal die ssmtp config:



    und hier die revaliases


    Code
    1. # sSMTP aliases
    2. #
    3. # Format: local_account:outgoing_address:mailhub
    4. #
    5. # Example: root:your_login@your.domain:mailhub.your.domain[:port]
    6. # where [:port] is an optional port number that defaults to 25.
    7. root:alias@domain.de:mail.domain.de:587



    Irgendwer ne Idee?

  • Ich nutze auch sSMTP mit Mailcow, ich habe folgendes anders:

    - keine Mail-Adresse im hostname, sondern einen Hostname

    - keinen rewriteDomain


    Ansonsten sollte es funktionieren... Versuch doch mal, über die Shell eine Mail zu schreiben:

    Code
    1. echo -e "asdfgrtasdvrwec" | mailx -s "Test" mail@domain.de

    Ich habe mich jedoch von Mails von fail2ban distanziert, ich wurde nur zugespammt davon, so viel war das

  • Danke erst mal für die Antwort. Aber an den ssmtp Settings kanns nicht liegen, da gehen die Mails ohne Probleme raus. Apticron etc. kommen ja auch alle an :)

    Irgendwo scheint es bei fail2ban zu haken :/

  • Code
    1. # ACTIONS
    2. #
    3. # Some options used for actions
    4. # Destination email address used solely for the interpolations in
    5. # jail.{conf,local,d/*} configuration files.
    6. destemail = root@localhost

    Kann es sein, das eine destemail gesetzt werden muss?

    Ist im Benutzerordner vom ausführenden Benutzer (root?) vielleicht eine dead.letter?

  • Code
    1. # ACTIONS
    2. #
    3. # Some options used for actions
    4. # Destination email address used solely for the interpolations in
    5. # jail.{conf,local,d/*} configuration files.
    6. destemail = root@localhost

    Kann es sein, das eine destemail gesetzt werden muss?

    Ist im Benutzerordner vom ausführenden Benutzer (root?) vielleicht eine dead.letter?

    destemail ist gesetzt, hielt. Ich nicht für nötig zum kopieren 😊 bzw. Klappte das ganze früher mit Sendmail via exim4 ja auch ohne Probleme. Denke mal es liegt eher an dem Sender da es dort zu Problemen mit ssmtp kommt.