E-Mailserver reagiert zu langsam?

  • Guten Morgen


    Ich habe vor einer Weile einen E-Mailserver gem. der Anleitung Thomas Leister neu aufgesetzt. Seit ich damit auf dem neuen RS1000 bin, habe ich jedoch das ein oder andere Problem und wollte mich mal erkunden ob die Reaktionszeit Problematisch sein könnte.


    Das eine Problem ist das ich bei diversen Firmen blockiert werde, und bei Microsoft keine einzige E-Mail durchbekomme. Gem. Microsoft gibt es mit der IP jedoch kein Problem. Da jedoch alle E-Mails überal reinkommen sobald ich die Server IP anstelle der Failover IP eintrage (DNS Einträge werden natürlich jeweils frühzeitig angepasst) kommen die E-Mails rein. Wie es scheint habe ich eine "Faule" Failover IP erhalten. Ich habe das mal dem NetCup support gemeldet. Ein Wechsel ist ausgeschlossen aber sie wollen mal bei MS schauen ob sie was erreichen. Naja.


    Ein spezielleres Problem ist der Text von MXToolbox. Hier erhalte ich immer mal wieder folgende Meldung:

    pasted-from-clipboard.png


    Manchmal muss ich 5 - 10 Versuche starten damit der Fehler weg ist, manchmal ist er beim zweiten mal weg.


    In der mail.log sehe ich nichts spezielles während der Abfrage von MXToolbox

    Code
    1. May 19 08:19:24 sven postfix/postscreen[15163]: CONNECT from [18.205.72.90]:50462 to [91.204.44.26]:25
    2. May 19 08:19:25 sven postfix/postscreen[15163]: PASS OLD [18.205.72.90]:50462
    3. May 19 08:19:25 sven postfix/smtpd[15166]: connect from keeper-us-east-1c.mxtoolbox.com[18.205.72.90]
    4. May 19 08:19:27 sven postfix/smtpd[15166]: NOQUEUE: reject: RCPT from keeper-us-east-1c.mxtoolbox.com[18.205.72.90]: 554 5.7.1 <test@mxtoolboxsmtpdiag.com>: Relay access denied; from=<supertool@mxtoolbox.com> to=<test@mxtoolboxsmtpdiag.com> proto=ESMTP helo=<keeper-us-east-1c.mxtoolbox.com>
    5. May 19 08:19:28 sven postfix/smtpd[15166]: disconnect from keeper-us-east-1c.mxtoolbox.com[18.205.72.90] ehlo=1 mail=1 rcpt=0/1 quit=1 commands=3/4

    DIe mail.err ist leer und die mail.warn hat nur ab und an diesen Eintrag:

    Code
    1. May 19 08:00:06 sven postfix/smtpd[15044]: warning: hostname hostmaster.meric.net.tr does not resolve to address 77.83.201.70

    Was es damit aufsich hat weiss ich aber grad auch nicht :)


    Ist der Timeout problematisch, und kann ich diesen irgendwie verhindern?


    Ich bedanke mich schon jetzt für jeden Hinweis.


    Gruss


    Oliver

  • kannst du die dazugehörenden Einträge der mail.log, welche mit diesem einem der mail.warn korrelieren posten?

    wobei: wer kommt auf die Idee einen Host hostmaster.... zu nennen, das wäre doch eher eine E-mailadresse hostmaster@...

    Grüße / Greetings

    Walter H.


    RS 1000 SAS G8 xRAM; RS 500 SSD G8; S 1000 G7; VPS 200 G8 Akt.; Webhost. 1000 m. 75%

  • Die Sache mit mxtoolbox sieht für mich wie ein Routing Problem aus, es ist ein Anbieter aus den USA.


    Das Log zeigt ja die Aktivitäten nach dem Connect und das ist doch okay.


    Quote

    May 19 08:00:06 sven postfix/smtpd[15044]: warning: hostname hostmaster.meric.net.tr does not resolve to address 77.83.201.70


    Das sieht für mich wie ein Spammer aus und ist normal.

  • kannst du die dazugehörenden Einträge der mail.log, welche mit diesem einem der mail.warn korrelieren posten?

    Gerne


    Code
    1. May 18 05:04:42 sven postfix/postscreen[4962]: CONNECT from [77.83.201.70]:36754 to [91.204.44.26]:25
    2. May 18 05:04:48 sven postfix/postscreen[4962]: PASS NEW [77.83.201.70]:36754
    3. May 18 05:04:48 sven postfix/smtpd[4965]: warning: hostname hostmaster.meric.net.tr does not resolve to address 77.83.201.70
    4. May 18 05:04:48 sven postfix/smtpd[4965]: connect from unknown[77.83.201.70]
    5. May 18 05:04:49 sven postfix/smtpd[4965]: NOQUEUE: reject: RCPT from unknown[77.83.201.70]: 450 4.7.25 Client host rejected: cannot find your hostname, [77.83.201.70]; from=<info@simpcinema.pw> to=<hostmaster@xxxxx.ch> proto=ESMTP helo=<simpcinema.pw>
    6. May 18 05:04:49 sven postfix/smtpd[4965]: disconnect from unknown[77.83.201.70] ehlo=1 mail=1 rcpt=0/1 data=0/1 rset=1 quit=1 commands=4/6

    Ich kenne den Absender auch nicht. Finde es einfach speziell das dieser Eintrag regelmässig erscheint. Denke aber auch nicht das der ein Problem ist

  • wollte mich mal erkunden ob die Reaktionszeit Problematisch sein könnte.


    Beim Aufbau einer Verbindung wird erst überprüft, ob der sendende Client/Server sauber ist (durch Blocklistenabfragen und Protokolltests). U.A. wird in den Tests deine Antwort absichtlich verzögern. Nichts Besorgniserregendes.

    Da jedoch alle E-Mails überal reinkommen sobald ich die Server IP anstelle der Failover IP eintrage (DNS Einträge werden natürlich jeweils frühzeitig angepasst) kommen die E-Mails rein.

    Sendet dein Postfix denn auch von der Failover IP? Oder sendet er von der normalen IP? Änderst du die Default Route entsprechend mit einer src Kennzeichnung? Sind beide Adressen auch als Sendeberechtigt im SPF Record markiert?


    bei Microsoft keine einzige E-Mail durchbekomme.

    Siehe Oben. Zusätzlich kannst du dich noch bei den Outlook Postmaster Tools anmelden und deine Adresse eintragen lassen.

  • Sendet dein Postfix denn auch von der Failover IP? Oder sendet er von der normalen IP?

    Er sendet von der FailOver IP


    Änderst du die Default Route entsprechend mit einer src Kennzeichnung?

    hier muss ich gestehen bin ich überfragt. kann ich das testen?



    Sind beide Adressen auch als Sendeberechtigt im SPF Record markiert?

    Normalerweise nur die Failover, aber für die tests war natürlich die serverIP drin

  • Bsp. in den Mail-Headern

    Im Mailheader wird keine IP angezeigt


    Ggf habe ich gestern auch geschlafen was du mit src meinst. Mein Server hat als Ausgehende IP die Original Server IP und nicht die Failover IP.

    Ich habe jedoch auch die Failover IP mal als Ausgehende verwendet (auch getestet)

    Code
    1. ip -4 route change default via <GATEWAY> src <FAILOVER>

    So wird mir die Failover als Ausgehende verwendet, die Mails bleiben trotzdem überall stecken und kommen nicht durch.

    Wäre dies überhaupt Relevant, da Postfix ja mittels smtp_bind_address an die IP gebunden wird?

  • die IP(v6) bei smtp_bind_address(6) ist auch diejenige, welche Postfix verwendet ...,

    und diese sollte tunlichst im SPF stehen ...

    Sorry das habe ich nicht erwähnt. Natürlich ist auch die IPv6 Failover eingetragen und auch per SPF Freigegeben.


    Da ich noch am schauen bin die IPv6 Adresse als Standard zu setzen, habe ich die IPv6 Adresse des Servers genommen und die IPv4 der Failover. Dies auch in Postfix konfiguriert. Die Mails werden von MS und einigen Firmen abgewiesen. Sobald die IPv4 die des Servers ist klappt es. Ich muss doch dann fast davon ausgehen das ich einfach ne "faule" Failover habe?

  • Wenn deine Emails abgewiesen werden, dann hast du Glück. Normalerweise verschwinden diese. Was steht im Log-File als Ablehnungsgrund?

    Hier kommen wir genau in das Schwere. Ein Grossteil der Nachrichten erhalte ich gar nie zurück und erhalte keine Bounce Meldung. Bei MS ist es das übliche "Please contact your Internet service provicer since part of their network is on our Block list (S3150). Bei den Firmen erhalte ich teils gar keine Rückmeldung oder Meldungen wie "refused to talk to me: 554) oder "Your access to submit messages to this e-mail system has been rejected (in reply to RCPT TO command)


    Den RBL-Status deiner IP kannst du mithilfe von z.B. http://multirbl.valli.org/ überprüfen.

    Danke den kenne ich. Dort werden mir auch sieben Einträge angezeigt, jedoch habe ich diese noch nicht hinbekommen auszutragen. Habe auch schon Beiträge gefunden bei denen diese Einträge als irrelevant angezeigt wurden.

    srn.surgate.net

    abuse.ch ZeuS Tracker Domain

    abuse.ch ZeuS Tracker IP

    AntiCaptcha.NET IPv4

    dnsbl.isx.fr

    dnsrbl.org

    openresolvers.org

    SurGATE Reputation Network (SRN)


    Dies liegt aber unter Umständen auch daran das diese Seiten teils gar nicht erreichbar sind und daher Fehler ausgeben.