ssh crash?

  • Hallo,

    ja wie der Betreff schon sagt, bin ich gestern aus meinem Server rausgeflogen. Und ich weiß nicht genau, warum. Ich habe einen RS 1000 G8. Darauf läuft Ubuntu 18.04 LTL, Php, mysql u.s.w.

    Der Webserver läuft nach wie vor gut, ich hatte bisher keine Probleme. Gestern habe ich die nextcloud noch um einen Dokumenten Server ergänzt (docker). Alles lief wie geschmiert.

    Dann habe ich noch ein Linux update/upgrade gemacht und da könnte es passiert sein. Für Openssh gabs ein Update, es gab auch eine Medlung, dass was nicht funktioniert hätte. Das ist mein erster Ansatz. Mein zweiter Ansatz ist, ich habe ein snapshot gemacht. Erst auf online snapshot, dann kam der Hinweis, offline ist besser.


    Irgendwann danach kam ich dann nicht mehr rein. "connection refused". Ich habe den Server natürlich neu hochgefahren und so. Nix zu machen. Wie gesagt, ein typischer Standard Server, normal abgesichert. Der ssh deamon scheint nicht mehr zu laufen. Das VNC Panel sagt "incorrect login". Aber am Passwort liegts nicht. Man hat ja gar nicht die Möglichkeit, sich anzumelden.


    Meine Fragen sind:

    a) Gibts noch irgendeine Möglichkeit, auf den Serer zu kommen?

    b) Gibts eine Möglichkeit, die Ursache herauszufinen?

    c) Wie kann man sich davor besser schützen? Viele Snapshots (aber wenn das die Ursache ist, wobei ich tippe auf openssh update, ur man muss ja mal ein Update machen)


    Danke für Tipps

  • Wenn Du Dich unter servercontrolpanel.de anmeldest (Kundennummer und Passwort), den Server anklickst (Auswahlliste links) und dann dort auf „Allgemein“ bist, gibt es rechts ein Bildchen mit einer Konsole. Wenn man da drauf klickt, wird eine VNC-Sitzung zum Server geöffnet.


    Du musst also nur noch Deinen Benutzernamen und Dein Passwort auf dem Server kennen, um das Problem mit SSH zu beheben. Es gibt aber manchmal Tastaturprobleme in der Art, dass manche Tasten nicht oder doppelt ausgewertet werden oder, dass eine falsche Tastaturbelegung vorliegt. In diesem Fall versuch es mit der virtuellen Tastatur.


    Wenn es eine Linux-Distribution wie Ubuntu ist, dann wird bei einem Systemupgrade manchmal auch eine „Failsafe-Instanz“ von SSH auf einem hohen Port gestartet - da müsste ich jetzt recherchieren. [Update: Es ist Port 1022.]

    ░▒▓Blog: https://grundsoli.de/▓▒░

    ░▒▓Gutscheine: https://netcup-groupie.de/▓▒░

  • a) Gibts noch irgendeine Möglichkeit, auf den Serer zu kommen?

    VNC Konsole im SCP oder Rescue Mode im SCP.

    b) Gibts eine Möglichkeit, die Ursache herauszufinen?

    Über die VNC Konsole den SSH Service restarten und anschließend ins Log gucken.

    c) Wie kann man sich davor besser schützen?

    Vorm Neustart sicher sein, dass das Upgrade alles korrekt erledigt hat.



    Was ist denn genau für ein Fehler beim Upgrade aufgetreten?

  • .Im Fall der falschen Tastaturbelegung findest Du die Änderungsmöglichkeit im SCP unter „Einstellungen“, „VNC Keyboard Layout“:

    Sollten es Fehleingaben aufgrund der anderen Anomalie sein versuch es mit der virtuellen Tastatur (nach einem Neustart sollte das Problem fallweise auch verschwinden.)


    Solltest Du tatsächlich Dein Passwort zum Server vergessen haben (nicht das ohnehin voreingestellte VNC-Passwort), findest Du im Menü des SCP einen Eintrag „Zugang“. Sofern der Server ein mit ext2/3/4 aufgesetztes Linux ist, kann darüber komfortabel das root-Passwort neu gesetzt werden.

    ░▒▓Blog: https://grundsoli.de/▓▒░

    ░▒▓Gutscheine: https://netcup-groupie.de/▓▒░

  • Wenn Du Dich unter servercontrolpanel.de anmeldest (Kundennummer und Passwort), den Server anklickst (Auswahlliste links) und dann dort auf „Allgemein“ bist, gibt es rechts ein Bildchen mit einer Konsole. Wenn man da drauf klickt, wird eine VNC-Sitzung zum Server geöffnet.


    Du musst also nur noch Deinen Benutzernamen und Dein Passwort auf dem Server kennen, um das Problem mit SSH zu beheben. Es gibt aber manchmal Tastaturprobleme in der Art, dass manche Tasten nicht oder doppelt ausgewertet werden oder, dass eine falsche Tastaturbelegung vorliegt. In diesem Fall versuch es mit der virtuellen Tastatur.


    Wenn es eine Linux-Distribution wie Ubuntu ist, dann wird bei einem Systemupgrade manchmal auch eine „Failsafe-Instanz“ von SSH auf einem hohen Port gestartet - da müsste ich jetzt recherchieren. [Update: Es ist Port 1022.]

    Wenn VNC gehen müsste, muss es ein Tastaturproblem sein. Weil die Zugangsdaten habe ich ja und auch nicht geändert. D.h., die gleichen Zugangsdaten, root oder ein andere sudo user? (Ich kann jetzt leider erst heute Abend weitermachen).

  • Ok, ich dachte, in die VNC Konsole komme ich auch nicht mehr. Bisher "incorrect login", scheint aber an der Tastatur zu liegen. Rescue Mode muss ich schauen, kenn ich noch nicht. Den Fehler weiß ich leider nicht mehr genau. Was macht man, wenn ein Fehler beim Update vorliegt. Dann ist ja schon alles gelaufen oder kann man das noch "rückabwickeln" oder erstmal simulieren?

  • Dann ist ja schon alles gelaufen oder kann man das noch "rückabwickeln"

    So lange Du nicht das System oder den betroffenen Service neu startest ist nichts verloren. Gerade SSH startet für jede Verbindung einen separaten Prozess, sodass Du in einer SSH Session den SSH Daemon kaputt machen kannst ohne raus zu fliegen.


    Klassiker sind neue Konfigurationsdateien welche vom Maintainer des Paketes geliefert werden. Wenn man da unbedarft auf "Ja, bitte ersetzen" tippt ist die eigene Config weg und man sperrt sich im schlimmsten Fall aus. Andere Probleme habe ich mit SSH bisher noch nicht gehabt. Ist eigentlich rock solid.


    Ich würde erst mal schauen ob der SSHd noch installiert ist, wenn nicht ihn wieder installieren und anschließend schauen ob der Dienst startet. Und wenn er das nicht tut im log gucken wieso nicht.

  • Du kannst das Tastaturlayout auch umstellen im SCP.


    Vielleicht sollte das deutsche Layout als Standard eingestellt sein, um Verwirrung zu vermeiden?

    RS 2000 Plus SAS G8 | VPS 2000 G8 Plus | VPS Ibiza/16 Years | 3x VPS 200 G8 | EiWoMiSau

    www.jeff24.de - www.serioese-alternative.de - www.jeff-media.de

  • Gibt mal in die Konsole sshd -t und poste die Ausgabe hier.


    Zudem könntest du per cat /etc/ssh/sshd_config die SSH Konfigurationsdatei aufrufen und diese mit deiner vergleichen (Backup vorausgesetzt)

    Ja, die sshd_config scheint defekt zu sein. Warum, weiß der Geier..

    sshd-t.PNG


    Den 1:1 Vergleich habe ich jetzt nicht. Aber das kann ja nicht alles sein. Ich hatte auch den Port verschoben. Oder ist das nur ein Teil der Datei...

    ssh_config.PNG


    Das kam als ich drüber installieren wollte:

    ssh_2.PNG


    Man findet den status 255 öfter: https://bugs.launchpad.net/ubu…urce/openssh/+bug/1780548

    Bin mir nicht sicher. Deinstalliern und dann neu? Muss man dann auch die Keys neu machen? Oder hat das weitere Auswirkungen?

    Was würdet Ihr mir empfehlen..?

  • "OOM" = OpenOfficeManager?


    Ne, wie der erste (und die weiteren) Google-Treffer. Aber das Problem scheint ja woanders zu liegen. Wie ist der komische Block bei dem sftpuser reingekommen? Da scheint nach einer Konfigurationsänderung jemand nicht geprüft zu haben um der Dienst seine Konfigurationsdateien noch verstehen kann.

  • Ne, wie der erste (und die weiteren) Google-Treffer. Aber das Problem scheint ja woanders zu liegen. Wie ist der komische Block bei dem sftpuser reingekommen? Da scheint nach einer Konfigurationsänderung jemand nicht geprüft zu haben um der Dienst seine Konfigurationsdateien noch verstehen kann.

    Erst hätte ich gedacht, kommt nicht von mir. Aber scheint so zu sein. Habe den Befehl in der Bash gefunden:

    sudo adduser sftpuser --ingroup www-data --shell /usr/lib/openssh/sftp-server --no-create-home

    Das war schon länger her. Jetzt läufts wieder. Danke für die Hilfe an alle.

  • Jetzt ist mir noch folgendes aufgefallen. Ich bin gerade dabei Visual Studio Code auszuprobieren. Dort wollte ich die SFTP App von liximomo nutzen. Hat ja sehr gute Bewertungen. Bei mir ist das allerdings etwas hackelig. Ich kann mich partou nicht mit SFTP verbinden. Jeder andere SFTP Client funktioniert.

    Das "witzige" ist, ich bekomme genau die Fehlermeldung "Unable to start subsystem: sftp". Und wenn man danach googelt, könnte man Abhilfe schaffen, indem ma:


    "turned out to be missing `subsystem sftp` in the `/etc/ssh/sshd_config file`: Subsystem sftp /usr/lib/openssh/sftp-server

    ```

    Also das, was bei mir zum "sftp crash" geführt hat... https://github.com/mscdex/ssh2/issues/115


    Schon komisch...ich versteh das nicht...

  • "turned out to be missing `subsystem sftp` in the `/etc/ssh/sshd_config file`: Subsystem sftp /usr/lib/openssh/sftp-serve

    Ich denke, ich habe die Lösung gefunden. Ich hätte den Eintrag Subsystem sftp /usr/lib/openssh/sftp-server nicht auskommentieren dürfen, den Block unten schon.