Verbindung zum Server wird andauernd unterbrochen

  • Hallo liebe NetCup.de Community,


    wir verwenden aktuell einen Server von euch (RS 1000 G7) für die Nutzung von GitLab und Jira.


    Wir konnten den Server einen längeren Zeitraum ohne Probleme nutzen, jedoch haben wir seit letzten Donnerstag/Freitag Probleme mit dem Server. Wir verlieren in zufälligen Zeitabständen die Verbindung zum Server, sei es per Browser der Zugriff auf gitlab oder eine Verbindung mit SSH zum Server direkt.


    Ich habe bereits alle Prozesse beendet und abgewartet jedoch mit dem gleichen Resultat. Die Logs zeigen keine Meldungen die zu den Disconnects zutreffen würden. Es wurden auch bereits unzählige Neustarts ausgeführt .


    Kann es sein das es ein Problem mit den Servern von NetCup gibt? Im Supportticket wurde uns gesagt es, dass nichts gemacht werden könne und es im grunde unser Problem wäre.


    Nachtrag:

    Über die Konsole im SCP habe ich diese Probleme im übrigen nicht!

  • Das hier ist ein "Kunden helfen Kunden" Forum, eine Antwort von einem Mitarbeiter, der das ganze technisch prüfen kann, wird es hier also eher nicht geben.

    Generell ist das beschriebene Fehlerbild jedoch auch etwas, sagen wir, allgemein gehalten.


    Wie äußern sich die Abbrüche?

    Wird die Verbindung vom Server abgelehnt? Kommt keine Antwort/der Client läuft in einen Timeout? Oder gibts doch ein (unwahrscheinliches) no Route Problem?


    Hier würden ggf. die Debuglogs der Applikationen, ein Dauerping, MTR,... helfen, um die "Ursache" wenigstens etwas eingrenzen zu können.

  • Kannst du das Problem im Rettungssystem reproduzieren? Wie thomba schon sagte: Am besten über längere Zeit google o.ä. anpingen bzw. tracerouten. Wenn du dann immer noch Netzwerkprobleme feststellst, Support-Ticket aufmachen mit dem Hinweis, dass auch im Rettungssystem Probleme auftreten.

    ChestSort: Automatische Kistensortierung in Minecraft - www.chestsort.de


    binichblau: Online-Promillerechner - www.binichblau.de

  • In Putty bekomme ich die Meldung "network error software caused connection abort" und bei einem erneuten Versuch per SSH zuzugreifen die Meldung das die Verbindung abgelehnt wurde. Nach ca. 30 Sekunden kann ich mich wieder für paar sekunden/minuten verbinden.


    Lustigerweise scheine ich nicht rauszufliegen solange ich pinge..

  • Habe den Server noch nicht so lange und bin noch am lernen.


    Habe jetzt über die Webkonsole und mit aktiviertem Rettungssystem ca. eine Stunde lang http://www.google.de gepingt und es traten keine Fehler auf. Aber über die Webkonsole hatte ich auch nie Probleme!


    Kernelfehler werden mit keine angezeigt und in /var/log/ habe ich alle Logdaten mal angeschaut und keine zu den Disconnects passenden Einträge gefunden bis auf, dass sich ein User eingeloggt hat.


    Das Pingen habe ich in IPv4 als auch in IPv6 durchgeführt - beide ohne Probleme


    Was die Fehlermeldungen mit Putty an geht, wenn ich mich einlogge über SSH kann ich für ca. 1-2 Minuten ohne Probleme arbeiten und kriege dann aber die Meldung "network error connection timed out" und bei erneutem Versuch auf den Server zuzugreifen kriege ich nur die Meldung "network error connection refused". Nach ca. 30 Sekunden warten ist wieder ein login möglich.


    Ich habe keine Firewall mehr an, da ich dachte das es dadurch kommen könnte.. Fail2Ban ist auch fürs erste ausgeschaltet und die SSH Konfigurationen sind es definitv nicht, da ich auch nicht mehr auf mein gitlab zugreifen kann.

  • connection refused

    Ich möchte an der Stelle nur darauf hinweisen, dass Connection refused in der Regel (wenn die Fehlermeldung richtig programmiert wurde) bedeutet, dass der Server generell zwar erreicht werden kann, aber die Verbindung aktiv ablehnt (im Gegensatz zum Timeout). In iptables-Terminologie wird quasi REJECTed und nicht geDROPed. Dies in Kombination mit dem über längeren Zeitraum funktionierenden Ping auf google im Rettungssystem lässt dann doch eher auf Fehlkonfiguration vermuten.


    Als anderen Aspekt möchte ich jedoch auch noch einwerfen, dass (lt. meinem Kopf) aktuell mehrere Threads von ähnlichen Problemen berichten...

  • Du hast lokal auf dem Rechner keine extra Firewall installiert und bist nicht über WLAN unterwegs und du hast echtes Internet (d.h. echtes IP 4)?

  • Ich hatte jetzt mal aus einem anderen Thread abgeschaut wie man traceroute über crontab laufen lässt und es über nacht laufen lassen gehabt


    Ich habe mehrfach die Meldung "google.de: "Temporärer Fehler bei der Namensauflösung. Cannot handle "host" cmdline arg "google.de" on position 1 (argc 1)" bekommen.